Jeep Patriot Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
108 Posts
Discussion Starter #1
So, I am getting (another) weird problem and am hoping someone has a quick fix for me.

Whenever I pull the windshield wiper switch to clean the windshield, the wiper fluid comes out on the rear window, but the front wipers come on. If I twist the column to clean the rear window, the fluid comes out the front, but the rear wiper turns on.

Any thoughts?
 

·
Registered
Joined
·
108 Posts
Discussion Starter #3
Yep. Randomly wanted to clean my windshield last week, so I pulled the switch toward me and the wipers turned on but the fluid was coming out onto the rear window.
 

·
Registered
Joined
·
5,441 Posts
I think our washer pumps are a reversing polarity type pump with a directional check valve on the dual outlets. So when it spins one way it, the check valve seal the rear outlet and it shoots out the front and when it reverses, the check valve seals the front outlet and it shoots out the rear. Maybe someone has played a joke on you and reversed the hoses at the pump?
 

·
Registered
Joined
·
108 Posts
Discussion Starter #5
Thanks for the info.

I thought someone might just be messing with me, but I am not sure who would have had access to my car other than myself (my wife, even if she wanted to play that kind of joke on me, wouldn't know how to pull it off).

I will double-check the hoses and see what happens.
 

·
Registered
Joined
·
1,630 Posts
So, I am getting (another) weird problem and am hoping someone has a quick fix for me.

Whenever I pull the windshield wiper switch to clean the windshield, the wiper fluid comes out on the rear window, but the front wipers come on. If I twist the column to clean the rear window, the fluid comes out the front, but the rear wiper turns on.

Any thoughts?
someone inverted your wiring
 
1 - 6 of 6 Posts
Top