Jeep Patriot Forums banner

7961 - 7980 of 7997 Posts

·
Registered
Joined
·
34 Posts
What lift was that...I have a 2" RR in the hopper maybe I should plan ahead?
Daystar 1.5" lift the arms i got are MOOG CK620066, and MOOG CK620065 about $80 each on rock auto, also you will want to get the Moog front sway bar links, there a thicker link and greasable. you will want to look out for the pass side front cv shaft, after lifting they tend to leak grease from the inner boot. lifting a patriot isn't all that straight forward lol.
 

·
Registered
Joined
·
6 Posts
Daystar 1.5" lift the arms i got are MOOG CK620066, and MOOG CK620065 about $80 each on rock auto, also you will want to get the Moog front sway bar links, there a thicker link and greasable. you will want to look out for the pass side front cv shaft, after lifting they tend to leak grease from the inner boot. lifting a patriot isn't all that straight forward lol.
Knightowl - about to do that Daystar lift as well. When you say to keep an eye on that inner boot, what are you doing? One of those split-CV cover boots or something?
 

·
Registered
Joined
·
6 Posts
No, going to replace the shaft once I find one that would be a solid upgrade. Why just fix when you can make it better.
[/Q
No, going to replace the shaft once I find one that would be a solid upgrade. Why just fix when you can make it better.
Honestly, I'm disappointed to hear that there are CV axle issues even with the Daystar. 1.5 inch sounded pretty safe. Are you running stock sized tires?
 

·
Registered
Joined
·
34 Posts
Honestly, I'm disappointed to hear that there are CV axle issues even with the Daystar. 1.5 inch sounded pretty safe. Are you running stock sized tires?
No, and there was 60k on them before the lift so since that boot and the arms are a issue unlifted the lift only accelerated the issues. you have to remember that whenever you modify a car you will run into other issues, even the most well made kit can and will have problems
 

·
Registered
Joined
·
157 Posts
New Pennzoil Platinum 5W-20 and Fram TG10060. Runs great and enjoys revving up through the gears.
 

·
Registered
Joined
·
835 Posts
On my drive in to work this morning I discovered that my heater isn't blowing hot air. Blows cold just fine. Yay, another project! (NOT!) I think that it's the blend door, as before I remember being able to hear when I would switch between hot and cold, and now I cannot. So I just went ahead and ordered the actuator on Amazon for $14. I also ordered sway bar end links and front sway bar bushings because the front end is making an awful racket whenever I hit the slightest bump.
 

·
Registered
Joined
·
330 Posts
Subframe check completed as fall is in the air! Slight surface rust on the rear crossframe. Wiped off the dirt and applied some fresh fluid film. Will do a bit more to the spots with some rust remover with an overspray of undercoating. Other than that, the subframe and other under body components looked good👍
 
7961 - 7980 of 7997 Posts
Top