Jeep Patriot Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
98 Posts
Discussion Starter · #1 ·
:smiley_thumbs_up:my front wipers started up by themselves first then the the rears and finally the washer started shooting water...all at the same time and the switch was off...there is NO fuse to pull...drove to dealer like this...unplugeed the units as this is the only way to stop them...said TIPM isshorted and would have to order a new one....over 1 week and still waiting....NICE...it is only 6 months old!
 

·
Off Road Enthusiast
Joined
·
1,391 Posts
Call them and be a little assertive - not rude - telling them you expect it to be fixed sooner rather than later and if you need to take it somewhere else you will. Call another local dealer to see if they have the part or can get it quicker...

That is crazy though. Wonder what people were thinking when they drove by you for a while!
 

·
Registered
Joined
·
12,876 Posts
Call it a safety issue, tell them you need a loaner if you need to drive on the highway. It is a safety issue, you need to have those.

Good luck. Let us know how it turns out.
 

·
Registered
Joined
·
98 Posts
Discussion Starter · #4 ·
update...2 weeks-3 trips to dealer...replaced tpm, and wiper switch...re-flashed...still broken and they can not figure out why. they had to disconnect the wipers and washer pumps...said they comminicated with "star" and still no solution...and it has of course been raining off and on...they are keeping my jeep yet another night. way to go Chrysler...should of bought a hyundai but wanted to help my fellow american workers. Sucker!
 
1 - 4 of 4 Posts
Top