Jeep Patriot Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have a 2016 Patriot and got the throttle body replaced about 3 years ago after my car suddenly started jolting and shutting off after coming to a stop. About 2 years ago I had the spark plugs replaced due to the Jeep not accelerating after reaching about 25-30 mph. Earlier this year, I noticed my Jeep jolting when idling and while driving. The RPM needle would dump like crazy while driving and it would be difficult to accelerate. I continued to drive it for about a month or two. One day a month or two ago while entering the highway going from 30-65 mph the car began to jolt aggressively and I could not accelerate past 25 mph. I was forced to drive in the emergency lane to take an exit to instead take the backroads. Took it to the shop and was told the spark plugs misfired. Had the spark plugs replaced and everything was back to normal but now, 2-3 months later, I am experiencing the early stages once again. The Jeep is jolting when idling and while driving. The RPM jumps quite often. It seems like when the A/C is on it gets 10x’s worse but I am still able to accelerate. What could be the issue?! (P.S. I’m at 132,213 miles currently) Any advice/help would be appreciated!!
 

·
Administrator
2014 2.0 5-spd FWD
Joined
·
9,123 Posts
Just a guess, but maybe a bad coil pack? Misfire under acceleration is a classic symptom of a coil problem. Are you getting any codes?
 

·
Registered
Joined
·
1 Posts
I have a 2016 Patriot and got the throttle body replaced about 3 years ago after my car suddenly started jolting and shutting off after coming to a stop. About 2 years ago I had the spark plugs replaced due to the Jeep not accelerating after reaching about 25-30 mph. Earlier this year, I noticed my Jeep jolting when idling and while driving. The RPM needle would dump like crazy while driving and it would be difficult to accelerate. I continued to drive it for about a month or two. One day a month or two ago while entering the highway going from 30-65 mph the car began to jolt aggressively and I could not accelerate past 25 mph. I was forced to drive in the emergency lane to take an exit to instead take the backroads. Took it to the shop and was told the spark plugs misfired. Had the spark plugs replaced and everything was back to normal but now, 2-3 months later, I am experiencing the early stages once again. The Jeep is jolting when idling and while driving. The RPM jumps quite often. It seems like when the A/C is on it gets 10x’s worse but I am still able to accelerate. What could be the issue?! (P.S. I’m at 132,213 miles currently) Any advice/help would be appreciated!!
I’m going through this now. I have replaced the throttle body and the acceleration sensor (not sure if that’s what it’s called). I have spent nearly $1,000 in repairs and I was 8 miles from shop when check engine light, throttle body light and traction stability light came on and it started sputtering. If I keep going, once it gets up to 2 rpms the traction light goes out and it stops sputtering. It does it again when I have to stop. I’m desperately need some guidance.
 

·
Registered
Joined
·
45 Posts
What both Sandstone and Ignatz said. Have you had a shop pull the codes? Can help narrow down whether a bad coil pack or bad throttle body or sensor. If throttle body or sensor was an aftermarket, could very well be bad. Having replaced various sensors and electronics on my Daytona, learned quickly NOT to use aftermarket for any electronics parts. Can often fail in 12 - 18 months or sooner.
 
1 - 5 of 5 Posts
Top