Jeep Patriot Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
Hey all,

So something strange that’s been happening to my 2015 Jeep Patriot is anytime I’m driving, my temperature gauge goes up past the half way mark but NEVER fully to “H”. (It’s a 2.0L automatic CVT engine if that helps) Now when I’m driving on the highway its more likely to happen and it goes all the way up to the next tick where the black arrow is showing in the picture. This has been happening for awhile now ever since I got the car at around 25k miles and it’s now currently around 32k miles at the time of writing. Now I’m not sure what’s causing this but the needle NEVER goes past the 3/4 tick mark when driving so in my mind the engine isn't overheating it’s just getting hot. And with all of this time driving, the car hasn’t overheated which is weird to me considering it’s been driving like this with a lot of miles on it. There are no codes or anything on the dash, it’s just the needle going past the mark but never fully to “H”. I also did put some coolant in the reservoir thinking the coolant might have been low but that didn’t change anything. The only time the needle goes back down is when my foot isn’t on the gas peddle and I’m gliding down the road or the heat is on. Should I be worried about this? Hope someone can help!
91823
 

·
Moderator
Joined
·
8,011 Posts
Yours runs hotter than either of the Patriots I've had (2008 2.4 CVT & 2014 2.0 5-spd). I have more of a problem getting it warm in the winter.

Patriots have two thermostats. It may be that one is failing and the other is compensating but not well enough.
 

·
Registered
Joined
·
172 Posts
Make sure that your electric cooling fans are coming on.
 
1 - 3 of 3 Posts
Top