Jeep Patriot Forums banner
1 - 17 of 17 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I have an 08 Patriot and the power locks, dome light, and some dash lights stopped working. I have already checked the fuses and they are good. If I measure the voltage of the fuse box ports I have proper voltage on one side and 2.5 volts on the other side which should have 0 volts.

Anybody know what to do to resolve this issue?
 

·
Registered
Joined
·
6 Posts
Did you ever figure this out? I have had the same exact problem with my compass for years but have never been able to fix it.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
There were some wires that were broken, I got them soldered back together and everything worked again
 

·
Registered
Joined
·
6 Posts
There were some wires that were broken, I got them soldered back together and everything worked again
If you are still out there...can you let us know where the wires were located on your car? I would PM you but it doesn't appear that I can.
 

·
Registered
Joined
·
8 Posts
How did you figure out which wire was bad? Thanks for your reply!
Probably this won't help you much, but who knows? In my case above issues were caused by an aftermarket auto-alarm. Looks like it stopped working properly after "flooding" from doors swivel. You could also check this http://www.calibersrt4.net/mechanic...l-short-power-door-locks-interior-lights.html if you haven't already.
Good luck. It cost me a lot of nerves, so I know how annoying this thing is :)
 

·
Registered
Joined
·
3 Posts
Resurrecting an old thread here, but I am experiencing the same issues with my 08 patriot. One day, power door locks, all interior lights and the heater control lights stopped working.

If this is a result of a broken/shorted/corroded wire, please advise where it is.

I have verified that all fuses are good and have 12VDC on both sides of the fuses, but no volts at door lock switch, or interior lights....with key on or off, no difference.
I have also verified that no broken wires in either front driver or passenger door boots.

any help would be much appreciated.
Mike
 

·
Administrator
Joined
·
7,226 Posts
The door locks and lamps are driven primarily by the instrument cluster.

Door lock power comes through fuse 10, goes through C7, pin 18 on the TIPM to C1, 10 on the cluster.

Interior lights and panel lamps are also driven by the cluster.

I would start by checking for corrosion/broken pins/broken wires on TIPM C7 connector ( especially pins 15,16, and 18 that supply power to the cluster), then follow the wires through the firewall to make sure there are no breaks. If power is getting to the cluster, then the cluster may have gone bad.

Please post back and let us know what you find.


93351


93354


93352


93346


Panel lamps:
93347



Interior lamps
93350



Door locks:
93349
 

·
Registered
Joined
·
3 Posts
Success!
Was able to find that the RD/BR wire from TPIM C7-18 to the C201 was failed, resulting in no voltage on the Instrument Cluster C1-10.

I wasn’t about to start pulling wire bundles apart to find a broken/corroded wire so simply pulled in a new wire. Soldered new wire to the backside of TPIM C7-18 (RD/BR) then ran a new wire through firewall to the C201 (RD/BR) and then soldered there. The C201 appears to be some sort of junction point between the TPIM and IC.

All interior lights came on, heater control lights came on, and able to lock/unlock all doors including the loft gate.

It is a bit scabby, but it works!!

thanks for the help.
 

·
Registered
2014 Sport 4X4 FD2 Off-road, Falken Wildpeak A/T, All weather & convienance group, EVIC, ATC, Hitch
Joined
·
1,792 Posts
Nice job!
 

·
Registered
Joined
·
1 Posts
Success!
Was able to find that the RD/BR wire from TPIM C7-18 to the C201 was failed, resulting in no voltage on the Instrument Cluster C1-10.

I wasn’t about to start pulling wire bundles apart to find a broken/corroded wire so simply pulled in a new wire. Soldered new wire to the backside of TPIM C7-18 (RD/BR) then ran a new wire through firewall to the C201 (RD/BR) and then soldered there. The C201 appears to be some sort of junction point between the TPIM and IC.

All interior lights came on, heater control lights came on, and able to lock/unlock all doors including the loft gate.

It is a bit scabby, but it works!!

thanks for the help.
I have had the same problem with my Patriot 07.First electrician could not solve the problem,second person replaced cluster saying that was the problem but still no joy.Then i came across this thread.Third auto sparky followed the instructions and bingo,success.Central locking,interior lights and heater controls lights all working.Wish i had found this information earlier.Thanks for posting this as it saved anymore headache and money.
 
1 - 17 of 17 Posts
Top