Jeep Patriot Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 · (Edited)
Hello, I'm at my wits end... Anyone have any ideas on my 2009 Patriot 2.0 Crd. It has the Volkswagen PD TDI engine.

Was fine, slowly developed a jerky acceleration on light to medium throttle from low rpm. Wide open throttle doesn't give jerkiness and full power seems to be present. The jerking is accompanied by the sound of the turbo actuator seemingly pulsing? The whistle from the turbo seems to change sound.

Anyway, I've replaced the turbo to intercooler hose due to slight wear at the top joint, the fuel filter. Have inspected the turbo shaft for wear or play but it's fine. I've removed and cleaned the egr. I've disconnected and vacuum tested everything connected to the vacuum module. The vnt actuator holds pressure and can be moved by hand, by the vacuum pump and by my diagnostic software through its full range with no issue. Egr valve holds vacuum fine, and there's 25 pressures at the tandem pump.

With the maf disconnected the car runs much, much better, so I replaced the maf with a new quality one. Exactly the same issue though with the new one, and may even be slightly worse. I've inspected the main intake hoses for leaks but can't see the intercooler itself. The maf voltages all look fine. Engine idles smoothly and doesn't rattle or knock etc.

No CEL, no error codes. Mpg much worse than normal, like 32 mpg. My diag software shows boost setpoint and actual following each other, but with the steps clearly shown in both, so guess it can't be turbo related if the setpoint has the jerks in it too. I'm at a loss anyway, any thoughts welcome. Thx
 
1 - 2 of 2 Posts
Top