Jeep Patriot Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a 2012 Jeep Patriot, none of my tail lights work, my turn signal, works on one side in the back and the other on the front. My headlight work on low beam on the left side, then when I switch to high beams the right side works while the left side doesn’t. Any ideas, all bulbs have been replaced as well as sockets. Not sure what to do
 

·
Administrator
Joined
·
8,082 Posts
Hi Delegante, welcome to the forum.

Problems like this are sometimes caused by issues with the grounds in the engine bay. The wires can corrode under the eyelet crimp or under the insulation where it can't be seen. The fix is to cut off the old eyelet, strip the wires back to good metal and add a new eyelet. More info on the grounds at the link below:

 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
Hi Delegante, welcome to the forum.

Problems like this are sometimes caused by issues with the grounds in the engine bay. The wires can corrode under the eyelet crimp or under the insulation where it can't be seen. The fix is to cut off the old eyelet, strip the wires back to good metal and add a new eyelet. More info on the grounds at the link below:

I completely re did all the grounding wires to no avail, any ideas on what to do next?
 

·
Administrator
2014 2.0 5-spd FWD
Joined
·
9,432 Posts
Although my symptoms were different, I had a corroded spot in the wiring harness directly below the battery. It's at least a place to look. In my case I had to get a new engine harness.
 

·
Registered
Joined
·
15 Posts
Yup helped my Dad out before he passed away with his problem grounds were corroded on the frame. I believe like seven grounds under one lug were the problem. I cut them cleaned them up and reinstalled and put some electrical grease on them all good. There are on the left side on the frame
 
1 - 8 of 8 Posts
Top