Jeep Patriot Forums banner
1 - 3 of 3 Posts

· Registered
Joined
·
57 Posts
Im in a similar situation. I just recently got an 07. The front marker lights are a mess. No driving lights on either side and one side no flasher. Both bulbs are good and Ive tested the wiring with a test light and theres power where it should be for both driving and blinkers. The whole double socket pigtail that jeep uses gives you twice the failure points. Once in the actual bulb socket and once where it plugs onto the pigtail with the 3 pins. Ive taken it apart and cleaned it up and have found it to be very sensitive to failure notification. As in even when the bulb seems to be working right it still flashes fast and sets off the dead bulb warning. Messing with the bulb in the socket makes it work normally again but pressing on it can set it back to failure mode. Replacement sockets are like $50 bucks, crazy. Im currently looking for a generic replacement pigtail to replace the whole thing with. I see lots of 3157 based ones on amazon for about 10 bucks a pair but dont know if I can get them to mount in the housings. Jeep has a 3 tab socket that is shaped weird. I dont mind having to modify the socket tabs or housing slots a bit to get something jammed on there. I just need it to work to pass inspection. Any suggestions would be appreciated.
 

· Registered
Joined
·
57 Posts
Guess just have to get it figured out! Yes it is a mess. Will let you know what I find to fix. Wonder if the TIPM has anything to do with it?
I dont know about the tipm but it turns out that one of the sockets is bad. With cleaning and such I was able to restore both sides flasher and one side driving light. One of the sockets is just too corroded on the driving light contacts. I swapped the 2 sockets from side to side and the problem follows the corroded socket.Did I mention that these stupid sockets were $50+.? And thats for a dorman part not oem. I would check the sockets for corrosion. Maybe yours just need a good cleaning.
 

· Registered
Joined
·
57 Posts
Just as an fyi, Ive solved my problem by replacing the socket on the one side, the bulb on the other.. Ive now got fully functioning running lights and blinkers. The socket alone was like $50 everywhere. I was able to get the whole parking light assembly with a new bulb and socket for under $30 shipped off ebay, Brand new tyc brand stuff.
 
1 - 3 of 3 Posts
Top