Jeep Patriot Forums banner
1 - 12 of 12 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter · #1 ·
Help, Right turn works properly. Activate Left turn,blinks twice,chimes and flashes rapidly. Bulbs are correct front and rear. Why is this happening only on Left turn? All other lights working
 

·
Administrator
Joined
·
8,545 Posts
Are the left front and rear bulbs both lighting?

If only the front bulb isn't lighting, it may be a bad socket, a broken wire at the socket, a bad connection at the TIPM, a bad ground connection at g110, or the TIPM isn't working properly.

Ground info below:
 

·
Registered
2008 Jeep Patriot Sport
Joined
·
5,488 Posts
Sandstone is correct. The fast flash is how the system notifies you of a bad bulb or a bulb not drawing enough power. A ground can be good enough to pass enough current for a continuity test of a multi-meter, but fail at higher draw of a bulb. If you've ever watched any South Main Auto videos on YouTube, you'll see him frequently use a headlight bulb on test leads to check grounds to really pull amps through it.
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #4 ·
Are the left front and rear bulbs both lighting?

If only the front bulb isn't lighting, it may be a bad socket, a broken wire at the socket, a bad connection at the TIPM, a bad ground connection at g110, or the TIPM isn't working properly.

Are the left front and rear bulbs both lighting?

If only the front bulb isn't lighting, it may be a bad socket, a broken wire at the socket, a bad connection at the TIPM, a bad ground connection at g110, or the TIPM isn't working properly.

Ground info below:
Ok,no front,side running lights. Left turn does blink Twice normal then back to rapid flash with error msg in dash saying Left Front turn signal lamp out. Rear works fine with running lites,turn and brake.Neither front gives me running lites. I'm stumped
 

·
Registered
Joined
·
3 Posts
Im in a similar situation. I just recently got an 07. The front marker lights are a mess. No driving lights on either side and one side no flasher. Both bulbs are good and Ive tested the wiring with a test light and theres power where it should be for both driving and blinkers. The whole double socket pigtail that jeep uses gives you twice the failure points. Once in the actual bulb socket and once where it plugs onto the pigtail with the 3 pins. Ive taken it apart and cleaned it up and have found it to be very sensitive to failure notification. As in even when the bulb seems to be working right it still flashes fast and sets off the dead bulb warning. Messing with the bulb in the socket makes it work normally again but pressing on it can set it back to failure mode. Replacement sockets are like $50 bucks, crazy. Im currently looking for a generic replacement pigtail to replace the whole thing with. I see lots of 3157 based ones on amazon for about 10 bucks a pair but dont know if I can get them to mount in the housings. Jeep has a 3 tab socket that is shaped weird. I dont mind having to modify the socket tabs or housing slots a bit to get something jammed on there. I just need it to work to pass inspection. Any suggestions would be appreciated.
 

·
Registered
Joined
·
3 Posts
Guess just have to get it figured out! Yes it is a mess. Will let you know what I find to fix. Wonder if the TIPM has anything to do with it?
I dont know about the tipm but it turns out that one of the sockets is bad. With cleaning and such I was able to restore both sides flasher and one side driving light. One of the sockets is just too corroded on the driving light contacts. I swapped the 2 sockets from side to side and the problem follows the corroded socket.Did I mention that these stupid sockets were $50+.? And thats for a dorman part not oem. I would check the sockets for corrosion. Maybe yours just need a good cleaning.
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #8 ·
I dont know about the tipm but it turns out that one of the sockets is bad. With cleaning and such I was able to restore both sides flasher and one side driving light. One of the sockets is just too corroded on the driving light contacts. I swapped the 2 sockets from side to side and the problem follows the corroded socket.Did I mention that these stupid sockets were $50+.? And thats for a dorman part not oem. I would check the sockets for corrosion. Maybe yours just need a good cleaning.
Thanks,thinking I have a ground issue. The marker lights have been cut. Only 2 of 3 wires on pigtails. Left flashes normal Right 2 flashes then rapid flash and dash tells me Bad bulb. Confused 3157A will not fit in socket 3757A does fit. Manuel calls for the 3157A. ??. Thanksbut think I have ex owner issues. Cannot get a signal on Marker wires in harness. Maybe needs to be programed to turn on. Rears everything works. Marker,turn,brake. Reverse. Tomorrow is another day! Thanks for good advice on trouble shooting.
 

·
Registered
Joined
·
2 Posts
Help, Right turn works properly. Activate Left turn,blinks twice,chimes and flashes rapidly. Bulbs are correct front and rear. Why is this happening only on Left turn? All other lights working
I just had the same problem on the right side, it was the g110 connection. When I took it off the fender the wires broke off in my hand. The dealership could not find it for me I tried to tell them, but they didn't listen. Not a hard fix but not a lot of room on the right side. I think the left side will be easier to do looks like more space.
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #10 ·
I have redone grounds. Found only 2 wires going to pig tail,therefore no marker lights, cannot get signal to markers,bur rear work,might try to jump onto those. As far as wipers replaced switch, no change rear shudders reset inst ,AC,Radio--everything 3-5 sec it will all come back! HELP
 

·
Registered
Joined
·
2 Posts
Are the left front and rear bulbs both lighting?

If only the front bulb isn't lighting, it may be a bad socket, a broken wire at the socket, a bad connection at the TIPM, a bad ground connection at g110, or the TIPM isn't working properly.

Ground info below:
Your left front bulb is no good on drivers side . Replace bulb
 
1 - 12 of 12 Posts
Top