Jeep Patriot Forums banner
1 - 3 of 3 Posts

· Registered
2014 Sport 4X4 FD2 Off-road, Falken Wildpeak A/T, All weather & convienance group, EVIC, ATC, Hitch
Joined
·
2,535 Posts
I replaced the cluster in my '14 a few years back. When I first started the vehicle after, I got a lot of warning lights and a lot of odd codes (such as fuel pump #2 codes) and the gauge readings were way off. I thought I would have to put the old cluster back in. However, the next time I started the vehicle everything was normal. Apparently it programmed itself. I did have to use AppCar DiagFCA to turn on the new features that the replacement cluster had, such as EVIC and enhanced TPMS. May not be the same experience since yours is an '07.

If you do swap out your cluster, note your mileage before you remove it, since the odometer of the new cluster will be different.
 

· Registered
Joined
·
54 Posts
Discussion Starter · #3 ·
I replaced the cluster in my '14 a few years back. When I first started the vehicle after, I got a lot of warning lights and a lot of odd codes (such as fuel pump #2 codes) and the gauge readings were way off. I thought I would have to put the old cluster back in. However, the next time I started the vehicle everything was normal. Apparently it programmed itself. I did have to use AppCar DiagFCA to turn on the new features that the replacement cluster had, such as EVIC and enhanced TPMS. May not be the same experience since yours is an '07.

If you do swap out your cluster, note your mileage before you remove it, since the odometer of the new cluster will be different.
Thank-you for the help. Gonna try 🤞🤞🤞
 
1 - 3 of 3 Posts
Top