Jeep Patriot Forums banner

1 - 20 of 33 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter #1
So I recently installed my remanufactured TIPM to help fix my no high beams activating issue and my high beams still do not work. I checked the wiring, grounds and everything seems to be fine. The low beams run off the same circuit as the high beams and my daylight/low beams function fine. I still am trying to pinpoint the problem. Any advice would be much appreciated.
 

·
Registered
2014 Jeep Patriot, North Ed.
Joined
·
263 Posts
Could be an issue with the switch itself. Do you have a scan tool with live data? You can check to see if the module is commanding the lights on, and if so recheck your wiring - if not, then swap the switch or module.
 

·
Registered
Joined
·
727 Posts
Go farther down the wiring harness to the relay block in the driver's side wheel well and check for corrosion/broken wires. You can access from inside wheel well by pulling back the inner fender liner.
 

·
Registered
Joined
·
45 Posts
Discussion Starter #5
Go farther down the wiring harness to the relay block in the driver's side wheel well and check for corrosion/broken wires. You can access from inside wheel well by pulling back the inner fender liner.
Oh thank you, I actually just put in a new switch today and still no high beams. That could be what is going on because I am running out of parts to throw at it lol.
 

·
Super Moderator
Joined
·
5,119 Posts
Did you try using the optical horn function (flash to pass) to try to activate the high beams?

92116


This is for a Cherokee but same thing applies to the Patriot:
 

·
Registered
2014 Jeep Patriot, North Ed.
Joined
·
263 Posts
Instead of throwing parts at it, you could troubleshoot. A multimeter isn't very expensive and has so many uses.
 

·
Registered
Joined
·
45 Posts
Discussion Starter #9
Instead of throwing parts at it, you could troubleshoot. A multimeter isn't very expensive and has so many uses.
I understand I have a multimeter. I didn't even know there was a relay block on the front driver's side. I will have to check there.
 

·
Registered
2014 Jeep Patriot, North Ed.
Joined
·
263 Posts
The service manual is a little pricey to purchase but is so handy, especially if you plan on keeping your pat for a long time. Also, many of the guys here are very happy to help and will post electrical diagrams and the procedures in the manual for troubleshooting if you don't mind waiting a day or two. It avoids the issue of part throwing which can get expensive and solve nothing. SandStone is an amazing guy and is always here to help
 

·
Registered
Joined
·
45 Posts
Discussion Starter #11
The service manual is a little pricey to purchase but is so handy, especially if you plan on keeping your pat for a long time. Also, many of the guys here are very happy to help and will post electrical diagrams and the procedures in the manual for troubleshooting if you don't mind waiting a day or two. It avoids the issue of part throwing which can get expensive and solve nothing. SandStone is an amazing guy and is always here to help
Thank you, I use alldata but I know there are specific manuals out there for my patriot. I did some troubleshooting today and I was pulling resistors from the resistor block and swaping them to see if a bad resistor could be the problem. I attempted to swap one of them and had to pull hard to get a resistor out and one of the prongs ended up snapping off inside the resistor block. I inspected closely and found that it was corroded and had blue fuzzies around the pin location. I am thinking that could be the problem child. Not sure if i can pull the old broken off resistor prong out and installing a new resistor would fix the problem.
 

·
Registered
Joined
·
45 Posts
Discussion Starter #12
I have to get my vehicle inspected soon and this is a problem I need to tackle fast. Thanks for the help everyone, much appreciated.
 

·
Registered
Joined
·
714 Posts
Have you tried sticking a new bulb in? While it is unlikely, it's not unheard of for both high beams to blow at the same time. Yes, hi beams and low beams are handled by a single bulb, but there are seperate filaments for each. It could possibly just be bad bulbs. You do need to get the relay box fixed though, there is a "Lamp Activation" relay in there... not sure if that's for the high beams though... but if that's the one that's corroded, there's your answer.

92172
 

·
Registered
Joined
·
45 Posts
Discussion Starter #14
Replaced both headlights and that did not solve the problem. The radiator relay fan was the one that had a prong break off inside the block. Not sure if that would cause a problem with highbeams not activating.
 

·
Registered
Joined
·
45 Posts
Discussion Starter #15
Going to attempt to replace the relay and the wiring that may be broken, hopefully I can solve this issue.
 

·
Registered
Joined
·
45 Posts
Discussion Starter #16
Replaced the relay and put a new terminal in. Still no hi beams and the lamp activation relay did not have any wires running to it and no relay was there. The hi beams were working a while ago and then they just stopped working. I guess at this point I will have to chase down wires.
 

·
Registered
Joined
·
1,040 Posts
Only have a minute to chime in here. Below is what my service manual states. Maybe tomorrow I can dig into it more:

Are those blue connectors OEM? Looks a bit odd to me.

HEADLAMPS WILL NOT SWITCH FROM HIGH TO LOW BEAMS, OR FROM LOW TO HIGH BEAMS​
1. Ineffective EMIC (CCN) inputs or outputs.​
1. Use a diagnostic scan tool and the appropriate diagnostic information for further EMIC diagnosis.​
2. Ineffective TIPM inputs or outputs.​
2. Use a diagnostic scan tool to test the TIPM inputs and outputs. Refer to the appropriate diagnostic information.
 

·
Registered
Joined
·
45 Posts
Discussion Starter #19
No the blue connectors are not OEM, before I purchased the vehicle there was wiring that has been done before
 

·
Super Moderator
Joined
·
5,119 Posts
No the blue connectors are not OEM, before I purchased the vehicle there was wiring that has been done before
Has this added wiring been thoroughly checked?
 
1 - 20 of 33 Posts
Top