Jeep Patriot Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
My 2010 Patriot has an inline plug, connecting 2 wires, laying loose on the splash guard under the coolant reservoir. I dropped the hood a little hard today and heard something fall. I didn't see anything on the garage floor so I looked under the hood. Could the noise have been the plug hitting something as it fell to the splash guard? What would this plug be connecting? Could it get wet sitting on the splash guard?
 

·
Registered
2014 Sport 4X4 FD2 Off-road, Falken Wildpeak A/T, All weather & convienance group, EVIC, ATC, Hitch
Joined
·
1,640 Posts
Hard to tell what it could be for without seeing it... in that area it could possibly be for something like the windshield washer pump... but it could also be for something else. It can get wet on the splash guard.
 

·
Registered
2014 Sport 4X4 FD2 Off-road, Falken Wildpeak A/T, All weather & convienance group, EVIC, ATC, Hitch
Joined
·
1,640 Posts
There's no way for me to tell without seeing it. Is the connector still plugged in, or did it fall because it came unplugged? If it came unplugged, just look for the other half of the connector and plug it back in. If it's still connected but the wires just came loose from wherever they were stuck, just get yourself a cable tie and tie it up out of the way somewhere.
 

·
Registered
2014 Sport 4X4 FD2 Off-road, Falken Wildpeak A/T, All weather & convienance group, EVIC, ATC, Hitch
Joined
·
1,640 Posts
I can't tell what its for, but it'll be good to zip tie it to something.
 
1 - 7 of 7 Posts
Top