Jeep Patriot Forums banner

141 - 145 of 145 Posts

·
Registered
Joined
·
196 Posts
Happy to help. Also I would note that a mine used a torx (r) 30 bit on the Coil.
Also an m6*1.0 x 20mm is a good replacement, when you loose a Coil bolt. I messed up and sheered the connector nipple off of Coil. A zip tie is holding it on. If you shear off the Coil nipple, the red connector CPA won't seat. You can override it with a dentalpick. I secured it with a zip tie.
My gaps had .054, ". The new ones are gapped at. 044.




Sent from my SM-N910V using Tapatalk
 

·
Registered
Joined
·
1 Posts
Thanks a lot for these guide

I just changed the sparks last saturday and with just 24000 miles they were very beat up. My patriot has the same power as brand new!!! It was very simple. However, I believe that I did something wrong. When I turn the ignition off it makes a tic tic tic noise for a couple of seconds. While running is ok and no rattle at all. Any clues or pointers?
Thanks in advance for your help.
 

·
Registered
Joined
·
163 Posts
Thanks to the original poster and all that have added information. Used this for the second time on my 2014 with 91k.
 

·
Registered
Joined
·
196 Posts
I just changed the sparks last saturday and with just 24000 miles they were very beat up. My patriot has the same power as brand new!!! It was very simple. However, I believe that I did something wrong. When I turn the ignition off it makes a tic tic tic noise for a couple of seconds. While running is ok and no rattle at all. Any clues or pointers?
Thanks in advance for your help.
I have the same noise when my wife's is turned off. Does it sound like 3 short "click" sounds one can make with their tongue and cheak?

Sent from my SM-N950U using Tapatalk
 
141 - 145 of 145 Posts
Top