Jeep Patriot Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I've had my 2016 Jeep Patriot for about a year and now had my 1st issue with it. I was making a loud humming noise from the rear on the high way which got louder as I sped up. I took it to a local shop (owner has a Jeep Renegade) and he discovered the left rear wheel bearing was dry, so we replaced it. Now, there's two squiggly lines next to the anti skid light that stays on, the anti skid button on the dash doesn't work. After driving forward about 100ft the 4WD! light comes on and at that point you can't lock in 4WD with the lever under the arm rest... He's putting it back on the lift, said there was a clip that his mechanic insists he replaced.....any advice?
 

·
Administrator
Joined
·
6,361 Posts
Hi Richard68, welcome to the site.

Go back to the shop and have them check to make sure the wheel speed sensor is properly installed, connected and working.

Also, verify that the hub that was installed has the magnetic ring for ABS, some of them don't.
 

·
Administrator
Joined
·
6,361 Posts
Thx, will do and let you know........now if I can just figure out how to delete the other 2 threads I started......
No worries, I'll take care of it.

Keep us posted...
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 · (Edited)
No worries, I'll take care of it.

Keep us posted...
Ok, got it back. He said he'd taken it apart and checked, put it back together, and didn't find anything. Suggested maybe to replace the speed sensor. ATM and not being a mechanic I said I guess.... It's still the same, after start up, I can engage and lock in the 4wd, and disengage it with the lever under the arm rest. The lights come on and go off except the squiggly lines with the car over them that is next to the light for using the engaging and disengaging the anti slip stayed on this time. After I start going forward at about 15mph, or a 100ft or so, the 4WD!, and now the ABS light comes on. After those lights come on I can no longer engage and disengage the anti slip with the dash button for that function. I can no longer also stop the vehicle and lock in and disengage the 4wd using the lever under the arm rest. That ABS light that now comes on is new but I'm guessing it's related. All I did was have the bearings replaced on the left rear. Is my Jeep Patriot safe to drive in town? Is it safe to drive on the highway now? (edit #1) I live over an hour away from Wichita Kansas where I might find a dealership that has an authorized Jeep mechanic and if they don't have one Topeka, Kansas or Kansas City are 1.5 and 2.5 hours away. Suggestions? ( edit #2) ALSO, does the 4WD! light being on mean the 4wd (usually comes on under the speedometer) is now locked in and I'm tearing up my treads on my tires when on dry pavement?
 

·
Administrator
Joined
·
6,361 Posts
Without knowing what error codes are present, I would say the 4wd is disabled (2wd only), as is the ABS/traction control system.

Did the mechanic check for error codes? Did they connect it to any type of scanner?

If the hub is the correct model w/ABS ring, and the sensor is good and properly installed, it's possible the hub could be bad.
 

·
Registered
Joined
·
6 Posts
99% chance that this is going to wind up being a wheel speed sensor and/or tone ring issue on the wheel hub. Something was damaged, disturbed, or left disconnected when the bearing work was done. Not much of a mechanic if they can't/don't have a scanner that can at least pull ABS codes and diag. If they can't figure it out, don't let them keep charging you while they guess and throw parts at it. Take it to a reputable shop that does brake work that can diag.
 
1 - 7 of 7 Posts
Top