Jeep Patriot Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
Hey Y’all,
I bought a 2012 patriot latitude 2wd in march. I love the jeep but the transmission seems to be the only downfall. I have changed the transmission oil and both filters, and I also had an auxiliary transmission oil cooler installed. However, I notice that there is still a solid whine when i’m hitting around or over 65 mph. As soon as i’m above 2500 rpms the whine starts. I’m in arizona and summer gets hot which is why I had the cooler installed. Planning to take it down to california in a few weeks but not so sure because of the transmission.
What have y’all found to work? Any advice would be greatly appreciated, Thanks in advance 👍🏼
 

·
Unsponsored Baja racer
Joined
·
4,732 Posts
Have your AC checked, just in case. I've read that it may be a similar sound. Also, are you using good quality(Amsoil, Valvoline, or maybe Castrol) CVT fluid? Proper level? Only time I had a problem with mine is when I changed the fluid too late and the belt snapped after 15,000 miles of slipping. Probably didn't help that I used Pentosin fluid either. I think I've heard a little whine on mine once before, on a longer drive at highway speeds, but not much. Never had the annoyingly loud whine I've heard about from others before.
 

·
Registered
2014 Sport 4X4 FD2 Off-road, Falken Wildpeak A/T, All weather & convienance group, EVIC, ATC, Hitch
Joined
·
1,397 Posts
IF the AC checks out, try draining a few mm of trans fluid out.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #4 ·
Have your AC checked, just in case. I've read that it may be a similar sound. Also, are you using good quality(Amsoil, Valvoline, or maybe Castrol) CVT fluid? Proper level? Only time I had a problem with mine is when I changed the fluid too late and the belt snapped after 15,000 miles of slipping. Probably didn't help that I used Pentosin fluid either. I think I've heard a little whine on mine once before, on a longer drive at highway speeds, but not much. Never had the annoyingly loud whine I've heard about from others before.
Thank you, i ended up taking it in to an AC place to get it checked out like you suggested and the condenser had a hole in it and just got it back. Hopefully it went away. Thank you 👍🏼
 
1 - 4 of 4 Posts
Top