Jeep Patriot Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I see that 2007 and 2008 had this problem. I have a 2015 Patriot. Already had some work done on front end. I heard subframe rusts out. Anyone having this problem too?
 

·
Administrator
Joined
·
5,976 Posts
Hi Tess, welcome!

I would hope your 2015 isn't having rust problems yet, but it's easy to check for. If you start seeing rust patches at the seams / welds of the subframe/crossmembers you can try spraying them inside and out with a rust prohibiter like Fluid Film or using a professional rust prevention provider like Krown, etc. Rust Protection & Lubricant

The ABS ESC 4WD lights can be caused by various things from bad wheel speed sensors to wiring issues, so if you're having that problem the first thing to do is get the error codes read to hopefully provide some direction. If you don't have a code reader/scanner a local auto parts store might be willing to do it for free.
 

·
Registered
2014 Sport 4X4 FD2 Off-road, Falken Wildpeak A/T, All weather & convienance group, EVIC, ATC, Hitch
Joined
·
1,121 Posts
The ABS ESC 4WD lights can be caused by various things from bad wheel speed sensors to wiring issues, so if you're having that problem the first thing to do is get the error codes read to hopefully provide some direction. If you don't have a code reader/scanner a local auto parts store might be willing to do it for free.
I'm having the same issue now and turns out it's my left rear speed sensor/bearing.
 
1 - 3 of 3 Posts
Top