Jeep Patriot Forums banner

1 - 20 of 33 Posts

·
Registered
Joined
·
203 Posts
Discussion Starter #1 (Edited)
5spd stumbling intermittently @ 75mph+ (EDIT: @ Idle also)

Happens at start of acceleration after coasting a bit and under light constant throttle. No audible sound from engine, but passengers can also feel the hiccup, lasting a few seconds.

Started today on the way to SF on a half tank of fuel, so bad gas isn't an issue.

No check engine light.

Only happens at the above speed and in 5th gear.

I would almost describe it like letting out the clutch too quickly where it jerks a bit, but not as harsh.
 

·
POTM November 2008
Joined
·
8,921 Posts
It surprises me that it doesn't show up in 4th, 3rd, 2nd, and 1st at the same RPM and because of that it leads me to think it may be the electronic throttle lag. It may also have something to do with the computer cutting off fuel while you are coasting. There are many things about the Patriot I love, but the number of things that rely on the computer is not one of them.

I'd love to be more help but there is nowhere in the midwest where I can drive 75 MPH.
 

·
Registered
Joined
·
203 Posts
Discussion Starter #3
Well be surprised no longer...

Happened twice this morning while idling at a stoplight.

I'll be dropping her off at the next available Dealer appointment.
 

·
Registered
Joined
·
255 Posts
Same thing was happening to me when going up mountain passes at med-high acceleration just after shifting, felt like a big gust of wind was pushing me back, very irritating. I posted this a while back, well over a year ago, there is a TSB for this and it has to do with re-flasing the ECU memory. Why I don't know, something to do with the fuel trim table being wrong under specific load conditions. The re flash worked, but your ECU will need to relearn you driving habits for a few trips, so MPG will fluctuate. I'll see if I can find the TSB for you, just take it in to the dealer and they can do it in about a half hour. This TSB came out really early in the Pat's life.
 

·
Registered
Joined
·
8 Posts
I encounter the same issue from time to time on my daily highway commute. Seems to be most common when under 2,000 RPM for me. Press the pedal, hesitation, feeling like stumbling, kicks in. I've had the rig stumble and stall once at a stop light when turning right (restart and was fine). Not bad fuel either. 08 Pat 4,800 miles; purchased new from dealer in November.
 

·
Registered
Joined
·
255 Posts
The computer controls all in this EFI engine, and I don't think it's mechanical, but it might be. I think if it was mechanical it would be a lot more consistent. I would have to say get your ECU re flashed at the delaer, it's free as long as it's under warranty. If that doesn't work, try something else. Might take some time to figure out, but hopefully it was like a lot of Pat owners, and the computer had a bad set of parameters for the engine.
 

·
Registered
Joined
·
860 Posts
Glad to have came upon this thread. My 5spd Patriot is great so far, but sometimes I do notice some jerkiness especially when picking up speed in 2nd and 3rd gear from low revs - around or below 2000, I think. Tends to happen when I push the gas pedal lightly, if I floor it a bit more it`s not so noticable. So I didn`t know if it was a problem with the car or with my driving habits - keeping the revs too low, especially in winter when the engine is still cold and trying not to over-rev it :icon_rolleyes:
 

·
Registered
Joined
·
27 Posts
I get a little lag out of mine some times. Feels like a stumbling right after I shift. Its nothing bothersome. Almost feels like its got a big holley carb stuck on it. I'm going to mention it to my dealor the next time I'm there though.
 

·
Registered
Joined
·
203 Posts
Discussion Starter #11
Thanks for bumping this up...Forgot to post some closure for this thread.

I couldn't get an appointment for a week and once I called it stopped happening and hasn't happened since?

Guess I'll have to wait for it to happen again, hopefully it won't.
 

·
Registered
Joined
·
203 Posts
Discussion Starter #12
Stupid Jeep making me look bad...

Went to Myers Flat, CA on Saturday and between mile 40 and mile 150 she repeatedly stumbled at any speed between 62-73mph. Seemed most frequent at 69-71mph. I pulled into a station for a bathroom break and made sure the gas cap was tight (Odd things a loose cap can do), it was tight and continued to do it a few more times. The rest of the trip (533 total miles) not one hiccup?

I do know she is stumbling/stalling for sure now as I witnessed the RPM's dropping about 500 then kicking back up.
 

·
Registered
Joined
·
203 Posts
Discussion Starter #14
Okay, they ordered a transmission mount for my 70mph whistling noise.

For the stalling they installed the latest flash hoping it will cure it. #68044229AB

Nothing has been released that I can find on-line yet.
 

·
Registered
Joined
·
203 Posts
Discussion Starter #15 (Edited)
Intermittent stalling has returned. It does it at all speeds now sometimes almost every time I shift and let out the clutch then it just disappears for days at a time. I was only experiencing the issue if I traveled further than 30 miles, now it happens during my 27 mile commute home.


She goes back in on Friday 05/22.
 

·
Registered
Joined
·
203 Posts
Discussion Starter #17
Vehicle only does it after full warm up...Ambient temp not a factor.

I spoke to my Dealer about having them install a Event Data Recorder, they said no it wouldn't make a difference because the newer vehicles already have that built into their Computers.

Any techs know if the above is true?

Can they look back x-number of hours if I note the times it occurs?

I know we can do that on our Sub Zero Refers and such.
 

·
Registered
Joined
·
203 Posts
Discussion Starter #18
Well she hasn't acted up recently so I went in this morning for my service appointment and talked to Jeep Service Adviser, no codes, no MIL so we decided to get her off of Costco fuel and onto Chevron or Shell for a few fill-ups to see if she stops doing it. They apparently had a Chrysler Pacifica that was acting up on Costco fuel and after switching it stopped.

Wish me luck.
 

·
Registered
Joined
·
822 Posts
<snip> we decided to get her off of Costco fuel and onto Chevron or Shell for a few fill-ups to see if she stops doing it.

Wish me luck.
I wish you luck. :)

Did the fuel change help? For what it is worth, I have almost exclusively used Shell and have had no problems such as you describe.
 

·
Registered
Joined
·
203 Posts
Discussion Starter #20
All has been well across 2.5 tanks, haven't taken a long trip yet so it still hasn't been fully tested.

Chevron only, have not tried Shell yet.

My shift knob broke this morning, well the chrome bezel on top of it...I'm going to blame Chevron which will allow me to blame the dealer for telling me to switch fuels. :D
 
1 - 20 of 33 Posts
Top