Jeep Patriot Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Not sure how to fix my problem. Ive been dealing with a intermitted Crank shaft Position sensor issue for about 1.5 years.
I checked the VIN # on the Mopar site and it shows someone had the S89 recall done on the unit. But still having the same issues.
Its a 2 wheel drive 2.0L model. What I have noticed is most of the time the issue comes back after we have had a big storm of wet weather or sometimes during it.
Or at least the issue occurs more often after that. anyway any chance like they messed up the recall and I'm able to ask them to do it again? Or is there something else I should look at?
 

·
Registered
2014 Sport 4X4 FD2 Off-road, Falken Wildpeak A/T, All weather & convienance group, EVIC, ATC, Hitch
Joined
·
1,640 Posts
If it acts up more in wet weather, it could be a wiring issue. Either a loose plug or cracks in the insulation.
 

·
Registered
Joined
·
1,217 Posts
The recall notice states that the Patriot (MK) has multiple wiring connectors to be replaced during the S89 recall. The repair involves splicing in new wiring connectors. Maybe they DID NOT do the recall correctly
.
"NOTE: (MK) Jeep Compass and Jeep Patriot vehicles will require the crankshaft position sensor, intake camshaft position sensor and exhaust camshaft position sensor wire harness electrical connectors replaced. Complete steps 22-35 for all involved sensor electrical connectors."

The complete recall service process here: .....you might want to inspect the wiring work if you have basic mechanical skills and knowledge.

I would assertively demand that a dealer look at your vehicle again, as you would not want to have a debilitating or deadly accident due to this problem. You are much better off trying to get FCA/Stellantis to fix this on their dime, for warranty purposes, and to cover future possible litigation needs. Establish a paper trail in case you have to Lemon Law it or for any future problems.

Maybe contact JeepCares here and ask for assistance.
 

·
Registered
Joined
·
1,253 Posts
Not sure how to fix my problem. Ive been dealing with a intermitted Crank shaft Position sensor issue for about 1.5 years.
I checked the VIN # on the Mopar site and it shows someone had the S89 recall done on the unit. But still having the same issues.
Its a 2 wheel drive 2.0L model. What I have noticed is most of the time the issue comes back after we have had a big storm of wet weather or sometimes during it.
Or at least the issue occurs more often after that. anyway any chance like they messed up the recall and I'm able to ask them to do it again? Or is there something else I should look at?
Hi there. Our team would be happy to discuss your concerns further to see where we can assist. Send us a private message to get started.

Kate
Jeep Cares
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #5 ·
Hi there. Our team would be happy to discuss your concerns further to see where we can assist. Send us a private message to get started.

Kate
Jeep Cares
Thanks for the reply Sorry for the late reply. we had a bunch of family issues and I honestly lost track of things. I'll send you a PM and see what you think I should do. As of today the problem is happening daily about 2 or 3 times during our drive in or home from work. I dont have a second car now and both my wife are really dependent and getting to work. So sometimes we have to sturggle a little bit with this issue. But I have convinced her now we have to get this issue fixed. She is just asking where to take it and what to tell them.
 
1 - 5 of 5 Posts
Top