Jeep Patriot Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I have no engine light on.
Symptoms
1. lacking power and poor accleration
2. rough idle when in drive
3. sputters when trying to accelerate abruptly or when pressing down on gass suddenly
4.rpm gauges sticks and jumps
5. something sounds like its not catching or missing or sticking maybe grinding in front left side of car when trying to accelerate abruptly
6. occasionally I will be trying to push on gas to go and the car will decelerate slightl

*Already replaced spark plugs and cleaned throttle body.
 

·
Moderator
Joined
·
8,307 Posts
I'm not a mechanic, but I doubt the grinding noise is related to the performance problems.

The grinding noise could be a lot of things -- bearing, CV joint -- I can only guess. Many Patriots have had early front-end problems, although mine have been fine. You didn't say what year your Patriot is. Worst case scenario is a rusted/failed subframe. That would be a safety issue so I suggest you check it pronto! If that's the problem, Jeep extended the warranty to 10 years on the frame so you may be covered.

As for the performance problems, maybe it's the catalytic converter? Or the ECM? Again, I can only guess but they're places to start.

Edit. PS, I'm sorry. :oops: You put the year in the title of your post and I missed it.
 

·
Registered
Joined
·
835 Posts
Just because your light isn't on doesn't mean that there aren't any codes stored. If you don't have a code reader, most auto parts stores will check codes for free. A faulty coil could also cause those symptoms... except for grinding.
 

·
Super Moderator
Joined
·
5,420 Posts
As mentioned, no CEL doesn't mean there aren't any codes. Get it checked for codes, both stored and pending.

Considering the past problems with radiator coolant always being low, I'd run a compression test.

A full electrical diagnostic at the dealer might not hurt either.
 
1 - 4 of 4 Posts
Top