cruise control - Jeep Patriot Forums
Jeep Patriot General Discussion General discussion for the Jeep Patriot

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 05-22-2019, 12:32 PM Thread Starter
Junior Member
 
Join Date: May 2019
Posts: 2
 
cruise control

what causes a cruise control to do this switch works and lights up on dash but when you get to 20 mph it stops. doesn't matter if its on or off when you hit 20 mph it freezes up and want come on again tell you restart
goat57 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 05-22-2019, 05:33 PM
Senior Member

 
Ignatz's Avatar
 
Join Date: May 2009
Location: NH
Posts: 7,368
  
Garage
Welcome! Please drop by the Newbie board and introduce yourself to the others on here. Nice gang we've got.

I've had other weirdness with my cruise control, but not quite like you describe. Mine will go for days refusing to engage, then it starts working again. Its been behaving well for maybe 6 months now, but last summer/fall it seemed to be a week on and a week off. Hard to figure. My only suggestion is maybe its linked to the clutch switch? Mine is a manual and the clutch sometimes prevents starting, a problem I solve by turning off the ignition, depressing the clutch again, and voila, it starts. I haven't had the starting problem since I had the cruise problem which is my only reason for suggesting the link.

Neither problem was ever solved, they just went away. My fingers are crossed.
Ignatz is offline  
post #3 of 4 (permalink) Old 05-22-2019, 07:26 PM
Senior Member
 
geddisleroy's Avatar
 
Join Date: Dec 2013
Location: Springfield Or.
Posts: 135
 
If anyone of the wheel speed sensor are not up to par then cruise won’t work.

MODS=Remote start.Chrome grill inserts & door handles, Chrome mirror covers,headlight & tail light trim. 2 din radio with DVD, navigation and back up cam. Curt Trailer hitch, Oil cooler & trailer light wire harness. Parking sensors. Automatic headlights.Dash cam. Rear 12v power outlets. 120 AC 800w power inverter.

My vehicles
2014 Jeep Patriot
2002 Chevrolet Silverado p/u.
1930 modal A Ford 4dr town sedan
1946 Ercoupe 415C Airplane
geddisleroy is offline  
 
post #4 of 4 (permalink) Old 05-24-2019, 02:34 PM Thread Starter
Junior Member
 
Join Date: May 2019
Posts: 2
 
I've had problem with both fronts sensors they went out about 2 years apart first one cruise never stopped working sec one went out cruise had already stopped working changing sensor was no help
goat57 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Patriot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome