ESP/ BAS LIGHT AND CHECK ENGINE LIGHT - Jeep Patriot Forums
JeepPatriot.com   JeepPatriot.com
The Jeep Patriot Enthusiast Resource


Notices

Jeep Patriot General Discussion General discussion for the Jeep Patriot

JeepPatriot.com is the premier Jeep Patriot Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
Enjoy JeepPatriot.com? Has the site helped you? If so, show your support! Become a Site Supporter!
  #1  
Old 07-07-2007, 04:42 PM
bbtgheman's Avatar
bbtgheman bbtgheman is offline
Junior Member
 
Join Date: Jul 2007
Location: baton rouge, la
Posts: 1
bbtgheman is on a distinguished road
ESP/ BAS LIGHT AND CHECK ENGINE LIGHT

Ia anyone else experiencing the esp/bas light on and the check engine light. Trying to find out if common problem and what was wrong to fix it. Taking to dealer monday or tuesday to get worked on. Have 2400 miles and DRL computer has went out and lights were strobing at all settings, sunroof leaks and now this. LIke vehicle, but starting to think may have been bad choice to buy.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-08-2007, 12:56 AM
Scotty1980 Scotty1980 is offline
Junior Member
 
Join Date: May 2007
Location: corning ny
Posts: 11
Ride: black jeep patriot, 4X4 FD1
Scotty1980 is on a distinguished road
My check engine light came on and it was a evap hose came off. dealer took care of it right away.
Reply With Quote Quick reply to this message
  #3  
Old 07-08-2007, 06:53 AM
johnda's Avatar
johnda johnda is offline
Senior Member
 
Join Date: Jun 2007
Location: Southold, NY, USA
Posts: 1,429
Ride: 08 Patriot, 03 Camry
johnda is on a distinguished road
bbtgheman,

You might have a poor ground connection or a short in the wiring harness. I had a Subaru Legacy wagon that had a similar problem. The eastern Long Island Subaru dealer( where I did not get the car from) cost me hundreds of dollars and never cured the problem. I finally returned to the city and went to my dealer in Glen Cove, where they finally removed the wiring harness and replaced it and cured the problem, but it cost me an additional $700. Sorry about the sunroof, I no longer get them because mine ALWAYS leaked after time. Once my wife stopped short at a light and a wave of water that had collected in the roof came rushing forward and washed over her! She was NOT happy!

Edit: One more thing, it's possible the CPU chip for the display is having a problem, but your dealer really needs to check the system out.

If I were you, I would go right to the dealer and have them correct those problems.
Good luck!

P.S. Please let us how things turn out and what the problem was after they fix it, so we can be on the lookout ourselves.

Last edited by johnda; 07-08-2007 at 10:47 AM.
Reply With Quote Quick reply to this message
  #4  
Old 07-11-2007, 10:21 AM
Confused..... Confused..... is offline
Junior Member
 
Join Date: Jul 2007
Posts: 1
Confused..... is on a distinguished road
I have been having the same problem. The engine light came on Thursday and they said that it was an evac. leak and cleared the code, and if it came back on to bring it back on in. Now, it is Wed. it is back and on and the dealership can't get to me until Monday...should I worry? I have 4600 miles on it and have not gotten the oil changed yet, would that trigger that engine light to come on?
Reply With Quote Quick reply to this message
  #5  
Old 07-11-2007, 12:31 PM
tinkwantsajeep tinkwantsajeep is offline
Member
 
Join Date: Mar 2007
Posts: 32
tinkwantsajeep is on a distinguished road
I've had the ESP/BAS light come on a few times, the dealer ordered some sensor for it but I haven't gone back yet to have it installed.
Reply With Quote Quick reply to this message
  #6  
Old 07-11-2007, 04:57 PM
johnda's Avatar
johnda johnda is offline
Senior Member
 
Join Date: Jun 2007
Location: Southold, NY, USA
Posts: 1,429
Ride: 08 Patriot, 03 Camry
johnda is on a distinguished road
Confused... It is vital that you get that oil and filter changed pronto. A new engine works little tiny bits of metal into the crankcase as it breaks in. The oil and filter need to be replaced at 500-1,000 miles and you are WAY past that mileage. Not changing the oil as recommended is a good way to wreck your engine's long life ability.

Update: I have been advised by others that the recommended oil change period is 3,000 miles per their Jeep dealer, including breaking in. Personally. I'll still get the first oil change at 1,000 miles, just for old times. I have owned all my cars since the mid 80's for extended periods (over 10 years) and religiously get the oil and filter changed within the recommended time or milage. Does that have anything to do with my cars lasting? I dunno, but I don't think it hurts!

Last edited by johnda; 07-28-2007 at 10:03 PM.
Reply With Quote Quick reply to this message
  #7  
Old 07-11-2007, 07:03 PM
Scotty1980 Scotty1980 is offline
Junior Member
 
Join Date: May 2007
Location: corning ny
Posts: 11
Ride: black jeep patriot, 4X4 FD1
Scotty1980 is on a distinguished road
My engine light came back on with the same code, the dealer isn't sure whats causing it. got to take it back tuesday.
Reply With Quote Quick reply to this message
  #8  
Old 07-28-2007, 07:28 PM
PAT's-riot's Avatar
PAT's-riot PAT's-riot is offline
Senior Member
 
Join Date: May 2007
Location: SE, PA
Posts: 226
Ride: '07 Patriot Sport-Metallic Green - 4x4FDI- 5 Speed
PAT's-riot is on a distinguished road
Has anyone resolved their enigine light problems..?

I am asking this because I have only 1500 miles and my "engine" light came on today.

According to the manual, this light comes on when a sensor detects an emissions problem.. like a loose gas cap, or other engine sensor related problems.

I tightened the gas cap and I started the engine and the light stays on, the manual also mentions that as long as the light does not blink it should not be a major problem.

If anyone can share any insight or a related expierience, please reply.. I already sent the dealer an e-mail and I will call them on Monday..
__________________
Ordered on 4-28-07 Received on 6-21-07
Reply With Quote Quick reply to this message
  #9  
Old 07-28-2007, 08:56 PM
hasty10805's Avatar
hasty10805 hasty10805 is offline
Senior Member
 
Join Date: May 2007
Location: Shrewsbury, PA
Posts: 805
Ride: Patriot Limited 4x4 FDII(SOLD)/SAAB 9-3/98Trooper
hasty10805 is on a distinguished road
If you disconnect the battery for like 10-15 min to reset the computer it might turn off and stay off! If you just go to the dealer they can scan it for you and find out what it is, and it will be under warranty no matter what!!! I hope this helps.
__________________
GOT TRAILS?
Reply With Quote Quick reply to this message
  #10  
Old 07-28-2007, 10:41 PM
PAT's-riot's Avatar
PAT's-riot PAT's-riot is offline
Senior Member
 
Join Date: May 2007
Location: SE, PA
Posts: 226
Ride: '07 Patriot Sport-Metallic Green - 4x4FDI- 5 Speed
PAT's-riot is on a distinguished road
Hey thanks for the advice...

I did some research and found this on Jeepforum.com:

Dealer Reflashed our PCM

--------------------------------------------------------------------------------

Hi there, I am new here so I am not sure if this has been discussed yet, but I did look around and didn't see it. On 02/07/07 our check engine light came on and there was a lot of what I describe as valve noise coming from the top end. We took it the dealer immediately and the next day they called and said the PCM needed to be flashed. They did the work and I asked for a copy of the Technical Service Bulletin. Here it is...

SERVICE BULLETIN NUMBER: 18-020-06 REV. A
GROUP: VEHICLE PERFORMANCE
DATE: SEPTEMBER 16, 2006

SUBJECT:
FLASH: Warm Weather Spark Knock and/or DTC P2173 **and/or P0452**

OVERVIEW:
This bulletin involves selectively erasing and reprogramming the Powertrain Control Module (PCM) ** and if necessary, the Transmission Control Module (TCM)** with new software and performing a memory reset to clear the adaptive memory of the PCM.

MODELS:
2007 (PM) Caliber
**2007 (MK49) Compass**

Note: This bulletin applies to models equipped with a 2.0l or 2.4l gasoline engine and CVT transmission (sales code ECN or ED3 with DAV) built on or after May 11, 2006 (MDH 0511XX) through and including August 16, 2006 (MDH 0816XX)

SYMPTOM/CONDITION:
Some cutomers may experience Spark Knock in warm ambient conditions (16 C (60 F) or higher).

The technician may find one or more of the following DTC's

P2173 - High Airflow/Vacuum Leak Detected (Slow Accumualtion) may be found in the PCM. This DTC may occur when a vehicle is driven from a higher altitude to a lower altitude (1372 meter (4500 foot) change).

**P0452 - Evap Pressure Switch Stuck Closed**

It goes on to describe the repair procedure.

Anyway, they flashed the PCM and told me that essentially the engines timing was off. This may be why experienced only 18 - 20 MPG. However, that may be due to my extremely heavy right foot.

Hope this helps someone.
__________________
Ordered on 4-28-07 Received on 6-21-07
Reply With Quote Quick reply to this message
  #11  
Old 07-31-2007, 10:51 AM
Fennepa Fennepa is offline
Senior Member
 
Join Date: Jan 2007
Posts: 452
Fennepa is on a distinguished road
My ESP/BAS OFF light just popped on last night (close to 6000 miles). I was at a stop light about 3 minutes later so I shut down the engine and started it back up. The light was back on but then went away as soon as I started rolling again.

Thoughts on this? Should I get it to the dealership?
Reply With Quote Quick reply to this message
  #12  
Old 07-31-2007, 01:55 PM
johnda's Avatar
johnda johnda is offline
Senior Member
 
Join Date: Jun 2007
Location: Southold, NY, USA
Posts: 1,429
Ride: 08 Patriot, 03 Camry
johnda is on a distinguished road
At 6000 miles, could it be starting to get "anxious" about getting the oil changed? Can they do that?
Reply With Quote Quick reply to this message
  #13  
Old 08-03-2007, 10:35 PM
drummajo3's Avatar
drummajo3 drummajo3 is offline
Member
 
Join Date: Mar 2007
Location: Indianapolis, IN
Posts: 77
drummajo3 is on a distinguished road
Send a message via AIM to drummajo3
Mine has done this twice now. Once when doing a sharp corner and another after starting the engine. Don't ask me why but they're going to hopefully be able to tell me when I take it to the dealership next week.
Reply With Quote Quick reply to this message
  #14  
Old 08-08-2007, 11:08 PM
drummajo3's Avatar
drummajo3 drummajo3 is offline
Member
 
Join Date: Mar 2007
Location: Indianapolis, IN
Posts: 77
drummajo3 is on a distinguished road
Send a message via AIM to drummajo3
Told the dealership about this yesterday when getting remote starter worked on (still not working yet) and they applied a TSB where they adjusted the steering column angle or something like that.
Reply With Quote Quick reply to this message
  #15  
Old 08-09-2007, 09:32 PM
PAT's-riot's Avatar
PAT's-riot PAT's-riot is offline
Senior Member
 
Join Date: May 2007
Location: SE, PA
Posts: 226
Ride: '07 Patriot Sport-Metallic Green - 4x4FDI- 5 Speed
PAT's-riot is on a distinguished road
Update on my check engin light...

Hello folks,
I just got my Pat back from the dealer, this is my first expieience with Jeep for service and I came away impressed with service there.

I dropped off my jeep with a list of issues and they fixed and adjusted everything in a timely manner without taking more than one day with me without my vehicle.

As it turns out they said that my catalytic converter is in a breaking in stage and the O2 sensor was reading off (lean fuel mixture) they ran a battery of engine tests and reset the PCM. They say everything is ok, and they checked to make sure the gas cap is seating properly.

I also had them adjust the driver window crank, so that when the window is closed the lever is not in my arms way when I rest my elbow on the doors ledge.

They repositioned a heatsheild that protects the gas tank.
They also tightened the bolt on my drivers seat and they could not hear a squeak i heard and strangely enough the sound went away..

My observed mpg went down mainly becuase of more frequent a/c usage

The dealer did a multi step inspection on everything, tire pressure, fluids etc.

At 1800 miles, I can't complain no major issues.
__________________
Ordered on 4-28-07 Received on 6-21-07
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Patriot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 02:08 PM.


Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.