Horn Relay Location????? - Jeep Patriot Forums
Electrical and Audio Discuss stereos, NAV, general wiring, lighting & GPS

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 04-20-2016, 12:33 PM Thread Starter
Junior Member
 
Join Date: Nov 2014
Posts: 12
 
Horn Relay Location?????

Where is the horn relay location?

I have a horn which is possessed. Honks now and then, normally at night ... lol

So, I guess it's time to throw some parts at it ...

Culprits, in their order of pricing, low to high ...

1. Horn Relay ?
2. Horn itself ?
3. Horn clock spring ?
4. Something else ???

Where is the horn relay located??? Not in the owners manual
Greazzer is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 04-20-2016, 12:45 PM
Senior Member
 
jack.allwardt's Avatar
 
Join Date: Feb 2008
Location: Bonney Lake, WA
Posts: 2,988
 
I'd vote for the horn clock spring--it may have lost tension....but, I "believe" that the relay is actually an electronic circuit on the confuser...check for loose connections, not that I know where the electrical panel is either!


Jack Allwardt, Bonney Lake (Tehaleh area), WA; (REPEAT Patriot Owner...'08 Limited and a '16 High Altitude), Retired engineer, US Army veteran, Member: American Legion, Veterans of Foreign Wars, Central Valley Vietnam Veterans, Enumclaw (WA) Lions Club. Former vintage military jeep owner, instrument rated commercial pilot, ag pilot, vintage aircraft restorer and test pilot.
jack.allwardt is offline  
post #3 of 5 (permalink) Old 04-20-2016, 06:00 PM
Senior Member
 
griff's Avatar
 
Join Date: Mar 2014
Location: Sanford NC
Posts: 590
 
A while back my horn stopped working. While trying to diagnose it, I read that our Patriots don't have a horn fuse or relay. I'm not 100% positive if that's true...I finally got mine working by whacking the horn with a wrench, lol.

griff is offline  
 
post #4 of 5 (permalink) Old 04-20-2016, 06:22 PM
Senior Member
 
jack.allwardt's Avatar
 
Join Date: Feb 2008
Location: Bonney Lake, WA
Posts: 2,988
 
Quote:
Originally Posted by griff View Post
A while back my horn stopped working. While trying to diagnose it, I read that our Patriots don't have a horn fuse or relay. I'm not 100% positive if that's true...I finally got mine working by whacking the horn with a wrench, lol.
See, it IS the clock spring mechanism...


Jack Allwardt, Bonney Lake (Tehaleh area), WA; (REPEAT Patriot Owner...'08 Limited and a '16 High Altitude), Retired engineer, US Army veteran, Member: American Legion, Veterans of Foreign Wars, Central Valley Vietnam Veterans, Enumclaw (WA) Lions Club. Former vintage military jeep owner, instrument rated commercial pilot, ag pilot, vintage aircraft restorer and test pilot.
jack.allwardt is offline  
post #5 of 5 (permalink) Old 04-21-2016, 09:46 AM Thread Starter
Junior Member
 
Join Date: Nov 2014
Posts: 12
 
I've seen various posts on the net, some saying the 2010 Patriot has no relays while others saying there are relays. So, that certainly has me puzzled. Those claiming no relays whatsoever seem pretty convinced and those who claim there are relays indicate they have replaced them ...

While poking around the engine bay yesterday, there are in fact a cluster of relays down by the horn, on the driver's side, sort of behind the fog light housing, catty-corner from the horn. Having said that, I have no earthly clue what those relays go to. Looks like 4 or so. I will take a picture this evening.

So, having said the above, those folks who claim the 2010 Patriot has no relays must be off base on that one.

I just don't want to get involved in the Stealership practices of swapping out parts.

I've ruled out the horn since that makes no sense to swap out. Something is energizing the horn and the horn itself only sounds when energized.

The "clock spring" looks like a PITA to swap out and it's sort of pricey ... $150-ish.

Hoping there are some relay(s) since that would be the quickest, easiest, and cheapest.

Overall, my daughter likes the Patriot but their track record has me leaning towards a new vehicle purchase .... 2010 with less than 60K on the clock but already getting a cluster of problems every few months ...
Greazzer is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Patriot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome