Battery problem - Jeep Patriot Forums
Electrical and Audio Discuss stereos, NAV, general wiring, lighting & GPS

 
LinkBack Thread Tools Display Modes
post #1 of 15 (permalink) Old 02-25-2009, 05:43 AM Thread Starter
Senior Member
 
alexp81's Avatar
 
Join Date: Nov 2008
Location: Kefalonia, Greece
Posts: 518
 
Battery problem

When I tried to start my engine last night, it didn't start. Battery was dead. I wired it to another car and managed to start it and then drove for a while so that it would fully charge. The battery indicator stayed on after more than 1 hour driving. I'm getting it to an electrician to check it and clarify whether it's a problem with the battery or with the charging system. Anyone had experienced same problem?

Slipping all the way to the edge...
alexp81 is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 02-25-2009, 05:52 AM
May 2009 POTM
 
deres's Avatar
 
Join Date: Sep 2008
Location: Athens, Greece
Posts: 847
 
Did you have any device (navigator, mp3 etc) left on your lighter input?
Man, that shouldn't happen to a brand new car...

deres is offline  
post #3 of 15 (permalink) Old 02-25-2009, 06:43 AM Thread Starter
Senior Member
 
alexp81's Avatar
 
Join Date: Nov 2008
Location: Kefalonia, Greece
Posts: 518
 
No, just the lighter.

Slipping all the way to the edge...
alexp81 is offline  
post #4 of 15 (permalink) Old 02-25-2009, 07:11 AM
Senior Member
 
- George -'s Avatar
 
Join Date: Dec 2008
Location: Melbourne, Australia
Posts: 667
 
You didnt leave the lights on hmmm?

The Green Diesel Machine


Coming soon... BFG's and new wheels
(err, might go for 20" wheels instead...)
- George - is offline  
post #5 of 15 (permalink) Old 02-25-2009, 07:25 AM
The Custom Guy
 
Mak001's Avatar
 
Join Date: Mar 2008
Location: Las Vegas, NV
Posts: 688
 
Sounds like your alternator is shot.

Jeep Patriot 4x2
Brilliant Black
October POTM
Mods: Custom Hiddin Sub Enclosure, Custom Interior/Exterior LED Lights, Body Matching Painted 17" Wheels, HID Projector Fogs, White CCFL Courtesy Lights, All around tint (20%), Molded Premium Mud Flaps, Mopar Slush Mats, Chrome Door Handles
Mak001 is offline  
post #6 of 15 (permalink) Old 02-25-2009, 09:14 AM
POTM Winner AUG. 09.
 
tiptronic's Avatar
 
Join Date: Jul 2007
Location: Cheltenham , Gloucestershire UK
Posts: 4,677
 
Send a message via Skype™ to tiptronic
Had a lot of complaints from Dodge Caliber guys , the batteries fitted by Chrysler from New are rubbish!! the cells collapse very easily. Get your battery checked for charge holding . Then straight round to your dealer for a new free one, under warranty!! I dont know about Jeep, but Dodge seem to know about it!

Just swapped red Classic X , for, Green Auto SE " Spirit " 2.5 Petrol Limited edition X still 4x4,


Ex 07 Patriot CRD Sport , UK ( with lots of chrome goodies )
tiptronic is offline  
post #7 of 15 (permalink) Old 02-25-2009, 12:13 PM Thread Starter
Senior Member
 
alexp81's Avatar
 
Join Date: Nov 2008
Location: Kefalonia, Greece
Posts: 518
 
The electrician told me that is 99% collapsed cell. Anyway he'll check it sometime by tomorrow and if it is battery will be changed under warranty. I only hope it's not the other 1% which I don't want to think about.
Vic, no lights on nor anything else. Was parked as usuall and just couldn't start.

Slipping all the way to the edge...
alexp81 is offline  
post #8 of 15 (permalink) Old 02-25-2009, 12:37 PM
Senior Member
 
spi8a's Avatar
 
Join Date: Dec 2008
Location: PATRAS, GREECE
Posts: 510
 
well my friend Alex go to out common dealer and tell them about the battery. I would advise you to talk with Panagioths (head mechanic) at the service of our dealer. He's a good guy and will help you better than the salesman that we bought our patriots. If you have any problem just inform me so I could help you from over here. You have already my phone number so call me for any assistance

MY LIFETIME LOVE: 2005 BLUE HONDA XL1000V VARADERO
spi8a is offline  
post #9 of 15 (permalink) Old 02-26-2009, 04:10 AM Thread Starter
Senior Member
 
alexp81's Avatar
 
Join Date: Nov 2008
Location: Kefalonia, Greece
Posts: 518
 
The electricial that checked the Pat confirmed the collapsed cell senario. Patra's authorized service adviced me to put a used battery for now and sometime get the car to them to replace the bad battery under warranty. George thanks for your offer, If I need anything I'll give you a call.

Slipping all the way to the edge...
alexp81 is offline  
post #10 of 15 (permalink) Old 02-26-2009, 08:19 AM
Senior Member
 
spi8a's Avatar
 
Join Date: Dec 2008
Location: PATRAS, GREECE
Posts: 510
 
ok Alex. As you wish. The good thing is that they are going to change it without charging you. That's the best part. Did you talk with Panagioths?

MY LIFETIME LOVE: 2005 BLUE HONDA XL1000V VARADERO
spi8a is offline  
post #11 of 15 (permalink) Old 02-26-2009, 08:44 AM Thread Starter
Senior Member
 
alexp81's Avatar
 
Join Date: Nov 2008
Location: Kefalonia, Greece
Posts: 518
 
I talked with Panagiotis among others. They all told me that I had to get over there so that they can replace the battery. I called Kostas (Triantafyllou) who sold me the car and ask him to do something. Within 10' they called back and said they'll ship a new battery tomorrow.

Slipping all the way to the edge...
alexp81 is offline  
post #12 of 15 (permalink) Old 02-26-2009, 04:23 PM
Senior Member
 
spi8a's Avatar
 
Join Date: Dec 2008
Location: PATRAS, GREECE
Posts: 510
 
well that's for sure. They want you to be for that change. But mostly they want to see what happen. I must admit I didn't wait such a good response snd he hesitates a lot. I had problems with him when I was going to buy my patriot. With the guys at the service I made my life easier and without any problems. With Costas I couldn't get the information that I wanted and he couldn't help me with the issues that I had. So if Costas helped you better than the service then you are a very lucky person.
Did they ship you the radio antenna too or not yet

MY LIFETIME LOVE: 2005 BLUE HONDA XL1000V VARADERO
spi8a is offline  
post #13 of 15 (permalink) Old 02-26-2009, 04:26 PM Thread Starter
Senior Member
 
alexp81's Avatar
 
Join Date: Nov 2008
Location: Kefalonia, Greece
Posts: 518
 
Oh yeah, I have already recieved my antenna. I hope I get the battery as well by tomorrow so I can proceed to the replacement and enjoy the weekend with a nice off-road...

Slipping all the way to the edge...
alexp81 is offline  
post #14 of 15 (permalink) Old 02-26-2009, 04:53 PM
Senior Member
 
spi8a's Avatar
 
Join Date: Dec 2008
Location: PATRAS, GREECE
Posts: 510
 
I hope that too Alex. Watch out this time my friend. Well I'm thinking to go for an off-road at night clubs in Patras

MY LIFETIME LOVE: 2005 BLUE HONDA XL1000V VARADERO
spi8a is offline  
post #15 of 15 (permalink) Old 02-28-2009, 09:18 AM Thread Starter
Senior Member
 
alexp81's Avatar
 
Join Date: Nov 2008
Location: Kefalonia, Greece
Posts: 518
 
After installing the new battery this morning, the patriot still didn't start the engine. After a check by another electrician the problem was solved. The wire that gives power to the engine starter was cut. The guy just replaced it and everything is fine now. I was missled by the first technician, although I had second thoughts abt his opinion.

Slipping all the way to the edge...
alexp81 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Patriot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome