Patriot 2008 electrical problem - Jeep Patriot Forums
Electrical and Audio Discuss stereos, NAV, general wiring, lighting & GPS

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 19 (permalink) Old 03-21-2013, 11:04 AM Thread Starter
Junior Member
 
Join Date: Mar 2013
Posts: 9
 
Arrow Patriot 2008 electrical problem

Hi, im new to Jeep. I always had Honda and Acura's over the last years. I also have some good overall knowledge about cars, but not with electrical problems (also sorry if my english is bad, im french).

Here's my story. 2 months ago, i bought a used 2008 Jeep Patriot North 4WD 2.4L from a used dealership.

Now, couple weeks ago, i went to work with my Jeep and everything was fine. After my shift, 8 hours later, I jumped in car and tried to start and nothing. Battery had power, i could use the radio, wipers, lights were on.. but couldnt start the car. The air bag and check engine lights were on and there were at least 4 or 5 beeps when i put key in, but couldnt start it.

I brought the car to a Jeep dealer and they told me that the problem was the fusebox under the hood. I was like a fusebox that break that easily on a 45,000km car. I had no choice but to get it repaired. Here is my "problem".

After they changed the fusebox (and a 1500$ bill (850$ for the part + job)), lot of electrical "accessories" were not like before and the dealership keep telling me i'm wrong. Here's an example of what changed.

- no more sound when i grab the handbrake,
- doors get locked at 20km/h, before they were locking when i press brake to shift on Drive,
- seatbelt light goes off when i pull belt, it was going off when i locked it before,
- when using wipers with windshield washer, now they wipe 2 times only, they were wiping 3 times before (i checked with a friend who has a 2008 patriot too and they wipe 3 times).
- rear passenger door doesnt lock/unlock anymore,

I know it's nothing important, but i am wondering what happened. Do told me they had to program the new fusebox in the computer..!? never heard of that in my life. But if they changed the computer's program, my question is.. when you change the under hood fusebox, do you ABSOLUTLY NEED to make any changes in the computer?

Also, when they fixed the fusebox, check engine and air bag lights were still on but car could at least start (yay!). The mechanic called Chrysler and they had no clue what was the problem. So they told me it was the PCM. They changed it under warranty.

So, i went to work, parked the car, came back 8 hours later and car would not start. The fusebox and PCM broke like that and bam..

Is this "normal" ? Do fuseboxes and PCM break that easily on these cars with this average kms? Anyone ever experienced something like this?


Any ideas?

Thanks and sorry for the long story
Le_Georges is offline  
Sponsored Links
Advertisement
 
post #2 of 19 (permalink) Old 03-21-2013, 11:21 AM
an odd member
 
cmoore's Avatar
 
Join Date: Sep 2011
Location: Greenwood,MS
Posts: 2,195
 
Patriot 2008 electrical problem

Except for the back door not unlocking the rest of the stuff sounds like it was an update to the Software in your Jeep... All of those things are what my my Pat has done from day one...

And for the PCM and fuse box… It does not sound like a normal wear and tear that most of the users here experience... You may have some wiring problems somewhere that is causing the two to short out some how... Some of the other members here will probably more of help but as far as most of your issues those are just updates


Sent from AutoGuide.com App



An Angry Mind is a Narrow Mind

Last edited by cmoore; 03-21-2013 at 02:37 PM.
cmoore is offline  
post #3 of 19 (permalink) Old 03-21-2013, 12:29 PM
MB
Seriously Addicted
 
MB's Avatar
 
Join Date: Nov 2010
Location: South Carolina
Posts: 4,070
 
^x2

I was going to say most of that sounds normal to me except for the door issue with it not locking /unlocking
MB is offline  
post #4 of 19 (permalink) Old 03-21-2013, 02:32 PM
Senior Member
 
Terasec's Avatar
 
Join Date: Sep 2006
Location: from NYC and have places in upstate NY and in PA
Posts: 4,508
 
Send a message via AIM to Terasec Send a message via Yahoo to Terasec
Fuse box controls a lot more than just fuse voltage function.
Hence the name tipm totally integrated power module.
As it contains more functions. Things will fail.
As for price, install/labor shouldn't be much.
1 hour labor.
Cost here in US is as follows at the dealer.
Tipm: $700
Install/labor: $100-$125
Reprogramming: $85.
And yes it has to be programmed with cars VIN#
Car won't function unless tipm is programmed.
Terasec is offline  
post #5 of 19 (permalink) Old 03-22-2013, 02:28 AM
Senior Member
 
goguadi's Avatar
 
Join Date: Jul 2010
Location: Breaza , Romania and Nea Trapezounta-Katerini , Greece
Posts: 1,630
 
Quote:
Originally Posted by Le_Georges View Post
Hi, im new to Jeep. I always had Honda and Acura's over the last years. I also have some good overall knowledge about cars, but not with electrical problems (also sorry if my english is bad, im french).

Here's my story. 2 months ago, i bought a used 2008 Jeep Patriot North 4WD 2.4L from a used dealership.

Now, couple weeks ago, i went to work with my Jeep and everything was fine. After my shift, 8 hours later, I jumped in car and tried to start and nothing. Battery had power, i could use the radio, wipers, lights were on.. but couldnt start the car. The air bag and check engine lights were on and there were at least 4 or 5 beeps when i put key in, but couldnt start it.

I brought the car to a Jeep dealer and they told me that the problem was the fusebox under the hood. I was like a fusebox that break that easily on a 45,000km car. I had no choice but to get it repaired. Here is my "problem".

After they changed the fusebox (and a 1500$ bill (850$ for the part + job)), lot of electrical "accessories" were not like before and the dealership keep telling me i'm wrong. Here's an example of what changed.

- no more sound when i grab the handbrake,
- doors get locked at 20km/h, before they were locking when i press brake to shift on Drive,
- seatbelt light goes off when i pull belt, it was going off when i locked it before,
- when using wipers with windshield washer, now they wipe 2 times only, they were wiping 3 times before (i checked with a friend who has a 2008 patriot too and they wipe 3 times).
- rear passenger door doesnt lock/unlock anymore,

I know it's nothing important, but i am wondering what happened. Do told me they had to program the new fusebox in the computer..!? never heard of that in my life. But if they changed the computer's program, my question is.. when you change the under hood fusebox, do you ABSOLUTLY NEED to make any changes in the computer?

Also, when they fixed the fusebox, check engine and air bag lights were still on but car could at least start (yay!). The mechanic called Chrysler and they had no clue what was the problem. So they told me it was the PCM. They changed it under warranty.

So, i went to work, parked the car, came back 8 hours later and car would not start. The fusebox and PCM broke like that and bam..

Is this "normal" ? Do fuseboxes and PCM break that easily on these cars with this average kms? Anyone ever experienced something like this?


Any ideas?

Thanks and sorry for the long story
check my thread on the relay box under the left fender behind the plastic wheel well cover.
i had a similar issue and it was pinned to 2 damaged relays due to corrosion.

[OlllllllO]
Eat,sleep,Jeep

2.0 CRD Limited,Lifted with StuCoils,1.25" wheel spacers,engine-transmission&gas tank skidplates,6000K HID conversion kit,rear parking sensors,tow bar,245/65/17 Lassa Competus A/T on League 208 Nocturne rims (summer tires),235/65/17 Kingstar RW07 on stock rims (winter tires), chrome grille,Patriot door sill guards,Startech Lifestyle leather interior,Husky Liners,Jeep aluminium pedal and dead pedal set.

Nothing like the sweet smell of Diesel
goguadi is offline  
post #6 of 19 (permalink) Old 03-22-2013, 02:01 PM
Senior Member
 
99_XC600's Avatar
 
Join Date: Aug 2012
Location: NorthEast
Posts: 261
 
On the Jeep...actually most vehicles there are 3 major components in the electrical system. They are the:

PDC - Power Distribution Center - Basically the fuse box and junction point for the wiring harneess and fuses
BCM - Body Control Module - Controls all things attached to the Jeep, (Radio, Wipers, lights, horn, remote entry etc etc)
PCM - Power Control Module - Controls all aspects of the engine , transmission and cooling

From reading the description it sounds like they changed the BCM or Body Control Module. When replacing any computer, the component needs to be flashed with the correct VIN otherwise it may not have the correct software. From everything you mention it sounds like they put in a new BCM and never flashed it.

One thing you didn't mention..Was this a Jeep/Chrysler dealership that did the repair? Since the software and tools are proprietary and only the dealership can do the repair correctly
99_XC600 is offline  
post #7 of 19 (permalink) Old 03-22-2013, 05:04 PM
Senior Member
 
2012 Cherry Patriot's Avatar
 
Join Date: Jul 2012
Location: Winston salem, NC
Posts: 251
 
Thats about normal. Mine is a 12 and does all those things since day one. Sounds like you got 11+ updates on an 08, lucky man! lol

However for the PCM and fuse box should not have broke. But that may be the cause of the 11+ updates in the PCM on 08 parts.... I really dunno, just throwing suggestions.

[SIGPIC][/SIGPIC]
2012 Cherry Patriot is offline  
post #8 of 19 (permalink) Old 03-22-2013, 07:47 PM Thread Starter
Junior Member
 
Join Date: Mar 2013
Posts: 9
 
Quote:
Originally Posted by 99_XC600 View Post
On the Jeep...actually most vehicles there are 3 major components in the electrical system. They are the:

PDC - Power Distribution Center - Basically the fuse box and junction point for the wiring harneess and fuses
BCM - Body Control Module - Controls all things attached to the Jeep, (Radio, Wipers, lights, horn, remote entry etc etc)
PCM - Power Control Module - Controls all aspects of the engine , transmission and cooling

From reading the description it sounds like they changed the BCM or Body Control Module. When replacing any computer, the component needs to be flashed with the correct VIN otherwise it may not have the correct software. From everything you mention it sounds like they put in a new BCM and never flashed it.

One thing you didn't mention..Was this a Jeep/Chrysler dealership that did the repair? Since the software and tools are proprietary and only the dealership can do the repair correctly
Yes repairs were done at a Chrysler/Jeep dealership. And yes, they changed the TIPM (got the right part number on bill) and the PCM (have no bill, it was on warranty). That's what they told me.


Quote:
Originally Posted by 2012 Cherry Patriot View Post
Thats about normal. Mine is a 12 and does all those things since day one. Sounds like you got 11+ updates on an 08, lucky man! lol

However for the PCM and fuse box should not have broke. But that may be the cause of the 11+ updates in the PCM on 08 parts.... I really dunno, just throwing suggestions.
This looks like they did an update but like you said, this looks like a '11 update in a '08.. they should have left the original '08 program in the '08 car imho...
Now if i have more problems later, i'll have to go back to the dealership and start over and pay again ><

That's why i asked if you guys, have a '08 patriot and if they do those things and if the program they put in, is the right one. Because at the dealership, they dont even believe me when i told them that lot of things have changed.

And no, that is not the problem why TIPM and PCM broke. I (and they) really have no idea. Like i said, i parked the car a 11:00PM (i work at night) and at 7:00AM, put the key in and car wont start even with power in battery and everything else working.. We even tried to "boost?" the car and nothing..

And thanks guys for taking some time to answer my questions! much appreciated

Last edited by Le_Georges; 03-22-2013 at 07:50 PM.
Le_Georges is offline  
post #9 of 19 (permalink) Old 03-31-2013, 12:37 PM Thread Starter
Junior Member
 
Join Date: Mar 2013
Posts: 9
 
Well, after the TIPM and PCM were replaced, Check Engine Light came back yesterday

Also, happened once, Alarm system light went on last week... dont know why because there is no alarm system on car.. wtf?

Going back to the dealership this week...
Le_Georges is offline  
post #10 of 19 (permalink) Old 03-31-2013, 08:54 PM
Senior Member
 
99_XC600's Avatar
 
Join Date: Aug 2012
Location: NorthEast
Posts: 261
 
Quote:
Originally Posted by Le_Georges View Post
Well, after the TIPM and PCM were replaced, Check Engine Light came back yesterday

Also, happened once, Alarm system light went on last week... dont know why because there is no alarm system on car.. wtf?

Going back to the dealership this week...
All Chrysler products since 2005 have a anti-theft system built into them. It's called the SKIM system and works with a transponder located within the key fob.

If you look at the ignition on the column, you will see a plastic ring around it. This is actually the atteana for the system and will read the transponder of the key when it's inserted into the ignition.If it doesn't match, the security light will become active and it will not allow the vehicle to start.

All I can say is be patient. Electrical issues absolutely suck. I had to deal with a major issue with my Liberty last year and I became well versed with all of the electrical systems in the Jeep. It even took the dealer 6 weeks to chase down the issue before it was finally fixed. In the end, my issue was caused by a broken wire from the gauge cluster to the ECM.
99_XC600 is offline  
post #11 of 19 (permalink) Old 04-02-2013, 03:29 PM Thread Starter
Junior Member
 
Join Date: Mar 2013
Posts: 9
 
I was wondering if the firmware version installed on my Pat can cause these troubles? I mean, when i had issues a couple weeks ago, if they put in a firmware for 2011+ Patriot, can it causes problems to my 2008? Do car's year and firmware version needs to match or a 2011 firmware can fit in any Pat's ?

Like i said earlier, i noticed many electrical differencies before and after my problem. So, that means the firmware wasnt correct when i bought the Jeep. That also means someone did some work on the PCM and/or TIPM (was the car stolen? had a major accident? i really dont know yet). But i will try to get some infos from Chrysler...
Le_Georges is offline  
post #12 of 19 (permalink) Old 01-04-2014, 01:53 AM
Junior Member
 
Patriot2010's Avatar
 
Join Date: Jan 2014
Posts: 1
 
Talking CrazyWild Patriot

Jeep Patriot 2010, built / bought late 2009
From what I see here, the problem I am having is due to BCM? I just had the software update done per recall, and my car is going beserk! It's been a couple weeks, but it started with dead battery , twice recharged at home. Tonight, after driving to the store and back, in terribly cold weather, I made sure everything was off when leaving. I had to go back out, and tried to lock with key remote, did not see interior lights come on when unlocking. I went inside and it was dinging, even with everything off. All warning lights on, funny sound coming from radio area, lights dimming, brights on but not. car would not lock/unlock...like aliens had been there. Map lights on but dim and could not switch off. Then the headlights dimmed, eventually one went out while other was on. Oh really?!
Will they charge me for correcting this bull? Will they tell me it was something else?
I love my Jeep regardless. It's great on the highway, and grips nicely when the Neon would not!
Patriot2010 is offline  
post #13 of 19 (permalink) Old 01-04-2014, 09:28 AM
Senior Member
 
todde702's Avatar
 
Join Date: May 2008
Location: Roslyn, PA
Posts: 5,413
  
Send a message via MSN to todde702
If you look in the owners manual, some of those things are user changeable. For example, how the doors lock/unlock can be changed by doing a series of key on/off cycles and pressing the lock button on the door within a certain amount of time.

-Todd
08 Sport 4x4 FDI Silver, CRD Stu's Coil Springs, Mud Flaps, Weathertech vent shades, TAG Rear Bumper
Carr Lightwing, Pilot Navigator Driving Lights, K&N Air Filter and a jp.com decal

Quote:
"Nothing is either good or bad, but thinking makes it so."
- William Shakespeare

"I swear to drunk I'm not God!"
- Anonymous
todde702 is offline  
post #14 of 19 (permalink) Old 05-07-2014, 01:31 PM
Junior Member
 
Join Date: May 2014
Posts: 1
 
I have a 2008/170.000. I adore it even when I couldn't start it in a snow storm. I've changed clutch switch - no go.
At dealership despite diagnostics at over 100 bucks nothing was found.
Car started but the next day it didn't.
Long story short: there is a black plastic box on driver side under the hood, below the headlight with four
relays. It is not sealed and all road and weather gets into it. Delicate relay fuses corrode and loose contact with the connecting wire harness. I pulled it up, opened, removed relays and white plastic seat, bought two new relays, inserted new wires, reinstalled relays, marreted new wires to thin grey with red stripe(three were loose - engine fan, starter and something else) wrapped box in plastic shopping bag and pulled it high beside fuse box, which is good and doesn't need replacement. Did it in March and so far no problem. Don't let yourself to be pulled in replacing whole wiring an the box. Get a good one from salvage, cut wires as long as possible and connect wires colour to colour. Takes some time and right crimpers, but it is way less than $1500 or more at the shop. And you'll feel good. When done, do not forget to wrap it up and place as high to the fuse box as you can, secure with a bungee art two. Have fun.
Jeepharness is offline  
post #15 of 19 (permalink) Old 05-07-2014, 02:31 PM
Senior Member
 
goguadi's Avatar
 
Join Date: Jul 2010
Location: Breaza , Romania and Nea Trapezounta-Katerini , Greece
Posts: 1,630
 
Quote:
Originally Posted by Jeepharness View Post
I have a 2008/170.000. I adore it even when I couldn't start it in a snow storm. I've changed clutch switch - no go.
At dealership despite diagnostics at over 100 bucks nothing was found.
Car started but the next day it didn't.
Long story short: there is a black plastic box on driver side under the hood, below the headlight with four
relays. It is not sealed and all road and weather gets into it. Delicate relay fuses corrode and loose contact with the connecting wire harness. I pulled it up, opened, removed relays and white plastic seat, bought two new relays, inserted new wires, reinstalled relays, marreted new wires to thin grey with red stripe(three were loose - engine fan, starter and something else) wrapped box in plastic shopping bag and pulled it high beside fuse box, which is good and doesn't need replacement. Did it in March and so far no problem. Don't let yourself to be pulled in replacing whole wiring an the box. Get a good one from salvage, cut wires as long as possible and connect wires colour to colour. Takes some time and right crimpers, but it is way less than $1500 or more at the shop. And you'll feel good. When done, do not forget to wrap it up and place as high to the fuse box as you can, secure with a bungee art two. Have fun.
exactly what happened to me in feb 13.
found two corroded relays,one with a broken pin.
wrote a thread on that.
wrapped the whole thing in a plastic bag.
no issues since.

[OlllllllO]
Eat,sleep,Jeep

2.0 CRD Limited,Lifted with StuCoils,1.25" wheel spacers,engine-transmission&gas tank skidplates,6000K HID conversion kit,rear parking sensors,tow bar,245/65/17 Lassa Competus A/T on League 208 Nocturne rims (summer tires),235/65/17 Kingstar RW07 on stock rims (winter tires), chrome grille,Patriot door sill guards,Startech Lifestyle leather interior,Husky Liners,Jeep aluminium pedal and dead pedal set.

Nothing like the sweet smell of Diesel
goguadi is offline  
Sponsored Links
Advertisement
 
Reply

Tags
2008, fusebox, patriot, pcm, tipm

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Patriot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome