Performance Difference: 2.0 VS 2.4 Engine - Jeep Patriot Forums
Engine and Drivetrain Engines, transfer cases, transmissions and axles

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 12-28-2010, 10:54 AM Thread Starter
Member
 
Join Date: Dec 2008
Posts: 59
 
Performance Difference: 2.0 VS 2.4 Engine

Easy Question:

Does the 2.4 L Patty Engine run any smoother, idle any better and do better on highway speeds passing/pulling into traffic than the 2.0?

My 2.0 runs rough at idle, with the a-c on at a stop light has stallled, with passengers couldn't accelerate up a steep hill and repeatedly needs fuel injection cleaner/ mid range gas to maintain best idle/performance.

It's been back to dealers repeatedly, computer's been changed and it still runs the same.

Is the 2.4 any better and will we feel any "seat of the pants" difference...including a smoother idle and no stalling with a-c on at stoplights running regular gas?
drshame is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 12-28-2010, 11:11 AM
Senior Member
 
Ignatz's Avatar
 
Join Date: May 2009
Location: NH
Posts: 4,218
  
My 2.4 runs smoothly. I got over 35000 out of my first set of plugs and it was only skipping a little under stress, never at an idle. I'm approaching 60,000 miles now and it still runs smooth as silk, even when it cold out (coldest its been here this year is 0 F). Starts fine even after being out in the cold all day.

Is your still under warranty? Lean on the dealer to fix it. I've never had a car from brand new to 10 years/250,000 that couldn't run smooth if appropriately tuned.
Ignatz is online now  
post #3 of 7 (permalink) Old 12-28-2010, 11:57 AM
Senior Member
 
todde702's Avatar
 
Join Date: May 2008
Location: Roslyn, PA
Posts: 5,413
  
Send a message via MSN to todde702
Ignatz makes a good point about the spark plugs. If you are near 30,000 miles (or over) and haven't done so yet, change the spark plugs. These engines use a standard, non-platinum tipped spark plug that need to be changed every 30k miles. Check/change the air filter too. You might also want to try the gas pedal reset trick or disconnect the battery for 30 minutes to reset the entire powertrain computer.

Lastly, if you haven't had the dealer change the oil and just used a quick change place, it's possible they may have used too thick of an oil. This would be a bit of a long shot I suppose, but maybe have the oil changed and make sure they use the recommended 5W-20. Some have posted that the VVT (Variable Valve Timing) will not work correctly with a thick engine oil. I personally run 5W-30 and have no issues with rough idles, but 10W-something (or higher) could be a problem.

-Todd
08 Sport 4x4 FDI Silver, CRD Stu's Coil Springs, Mud Flaps, Weathertech vent shades, TAG Rear Bumper
Carr Lightwing, Pilot Navigator Driving Lights, K&N Air Filter and a jp.com decal

Quote:
"Nothing is either good or bad, but thinking makes it so."
- William Shakespeare

"I swear to drunk I'm not God!"
- Anonymous
todde702 is offline  
post #4 of 7 (permalink) Old 12-28-2010, 01:35 PM
Senior Member
 
jeelo's Avatar
 
Join Date: Apr 2007
Location: Toronto-Scarborough
Posts: 549
 
wow, get ur dealership to fix those issues. Although you have the 2.0 I don't think you should be having those kind of issues.

I have the 2.4 that runs amazing! I can go uphill pulling a boat/trailer (1800-1900lbs) with ease, and thats with the jeep loaded with fishing/camping gear and cool full of beer and food. I can even do all this with the AC running.

I have changed my spark plugs and air filter at 50,000kms. I also use fuel injector cleaner in my fuel tank at every oil change (5000kms)


2008 North Edition FDI 26E|BrilliantBlack|YES Essential Pebble Beige Int.|Wheel&Tire Group|Power Express Sunroof|Cruise|locking gas cap|2" Hidden Hitch|Thule45050 cross bars|20" ASA JH8 Rims|BlazerTech2200 4" Fogs|Garmin260 GPS Unit|Panasonic CJ-DA6910 6x9s|Sony XSV6942A 6x9s|CR-V Cargo floor/portable table|Lamin-X tinted light covers|Husky Liners|Front tints (23%)|In-channel Window Vent Visors|235-65-17 Nexen RoadianAT2 for the winter
jeelo is offline  
post #5 of 7 (permalink) Old 12-28-2010, 01:37 PM
Senior Member
 
jeelo's Avatar
 
Join Date: Apr 2007
Location: Toronto-Scarborough
Posts: 549
 
....or check/replace the fuel filter. If I recall, many owners here found that the original fuel filter was getting clogged rather easily and when they changed the fuel filter it alleviated many of their issues.


2008 North Edition FDI 26E|BrilliantBlack|YES Essential Pebble Beige Int.|Wheel&Tire Group|Power Express Sunroof|Cruise|locking gas cap|2" Hidden Hitch|Thule45050 cross bars|20" ASA JH8 Rims|BlazerTech2200 4" Fogs|Garmin260 GPS Unit|Panasonic CJ-DA6910 6x9s|Sony XSV6942A 6x9s|CR-V Cargo floor/portable table|Lamin-X tinted light covers|Husky Liners|Front tints (23%)|In-channel Window Vent Visors|235-65-17 Nexen RoadianAT2 for the winter
jeelo is offline  
post #6 of 7 (permalink) Old 12-28-2010, 06:34 PM Thread Starter
Member
 
Join Date: Dec 2008
Posts: 59
 
It's now somebody else's problem.
For the past 2 years, multiple dealerships and factory reps changed out parts/computers/filters and it still had a rough idle at stop lights with the a-c on as it always is in S. Fla.

Found a 2011 Latitude,2.4 L/ Auto 4X2, Black Pearl, Leather Trimmed, Nav/Media Center, 17 Inch Tires, Alloy Rims.

Tires feel different, handling feels crisper as if they tweaked the suspension/steering...and the extra 20 HP is easily felt in the seat of the pants.

Road feel is different, definitely smoother and it could be the tire combination.


Highway Acceleration seems improved, could be a possible axle difference if there is one.

Overall upgraded experience from the basic '09 2.0 Sport we had.

Leather steering wheel, seating surfaces and nav/media center add just enough bling...but not too much.

Last edited by drshame; 12-30-2010 at 11:10 AM.
drshame is offline  
post #7 of 7 (permalink) Old 12-28-2010, 08:28 PM
Senior Member
 
christo827's Avatar
 
Join Date: Nov 2010
Posts: 118
 
Problem solved. LOL. Congratulations and welcome to the 2.4 club!
christo827 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Patriot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome