Transmission whining and slowing 2008 Patriot down to 40 mph - Jeep Patriot Forums
Engine and Drivetrain Engines, transfer cases, transmissions and axles

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 25 (permalink) Old 09-29-2010, 08:12 AM Thread Starter
Junior Member
 
Join Date: Jul 2010
Location: Texas
Posts: 10
 
Transmission whining and slowing 2008 Patriot down to 40 mph

I have a 2008 Jeep Patriot that has 84000 miles. It recently has started making a high pitch noise when pressing the accelerator. It is very evident when I travel longer distances. Last week after 90 miles the light came on for the transmission being too hot. It slowed the vechicle way down and we had to pull over and stop.

I took my Patriot in to have it looked at. The dealership said they couldn't find anything wrong (no codes and they couldn't get the check transminssion light to come on). They said they updated a computer part for the transmission. They said if it happened again (the check transmission light comes on and the transmissions whines and slows you down to 30-40 mph) to bring it in with the light on. I paid my $ on went on my way.

Well it happened again. Only problem was we were 5 hours from the dealership and 4.5 hours from home. We traveled at 35 miles an hour for almost 45 miles. We finally pulled over at the first station and let it sit for 45 minutes. The light did go off and we made it home safely.

I took it back to the same dealer (only one close). Four days after dropping it off they called and said "they finally got a code from the computer", it was part of the transmission that was not covered under warrenty because it did not have fluids involved (?). Does anyone have a clue what they are talking about? I have emailed the service dept. and have asked for a written reply to exactly what they were doing. This was 4 days ago.

I want to give the Patriot to my daughter for a graduation gift, but at this point I am very skeptical about it reliabilty. Worse yet, I am skeptical about it being 'fixed'.

Any suggestions?
WeaponZero is offline  
Sponsored Links
Advertisement
 
post #2 of 25 (permalink) Old 09-29-2010, 10:48 AM
sab
Junior Member
 
sab's Avatar
 
Join Date: May 2010
Posts: 16
 
A lot of us are experiencing the same with the "07" "08" models. Its probably the CVT. If you search these threads your not the only one. I called Chrysler to complain a week ago and obtained a case #....havent heard from them since, Im only out of warranty for about 2 months
sab is offline  
post #3 of 25 (permalink) Old 09-29-2010, 10:50 AM
sab
Junior Member
 
sab's Avatar
 
Join Date: May 2010
Posts: 16
 
By the way it should be covered by your warranty.
sab is offline  
post #4 of 25 (permalink) Old 09-29-2010, 11:08 AM
Senior Member
 
dixiedawg's Avatar
 
Join Date: Sep 2009
Location: Coudersport, PA
Posts: 12,810
  
Garage
I would think anything on the tranny would be part of the power train warranty? The lifetime warranty was due to folks being leery of the new tranny design.


You can go fast, but I can go anywhere
dixiedawg is offline  
post #5 of 25 (permalink) Old 09-29-2010, 11:42 AM
Senior Member
 
todde702's Avatar
 
Join Date: May 2008
Location: Roslyn, PA
Posts: 5,413
  
Send a message via MSN to todde702
The only part of the transmission that does not involve fluids would be the PRNDL switch and the front CV half-shafts. The rest of the tranny is a sealed unit. If it's a 4x4, there is also a Power Take-Off Unit (PTU) bolted to the right side transmission output to send power to the rear, but the PTU is definitely part of the power train. Find out from them exactly what part "doesn't involve fluid" that would cause the transmission fluid to over heat and is not part of the power train.

-Todd
08 Sport 4x4 FDI Silver, CRD Stu's Coil Springs, Mud Flaps, Weathertech vent shades, TAG Rear Bumper
Carr Lightwing, Pilot Navigator Driving Lights, K&N Air Filter and a jp.com decal

Quote:
"Nothing is either good or bad, but thinking makes it so."
- William Shakespeare

"I swear to drunk I'm not God!"
- Anonymous
todde702 is offline  
post #6 of 25 (permalink) Old 09-29-2010, 12:03 PM Thread Starter
Junior Member
 
Join Date: Jul 2010
Location: Texas
Posts: 10
 
I will call Chrysler as well...
WeaponZero is offline  
post #7 of 25 (permalink) Old 09-29-2010, 12:08 PM
Senior Member
 
Join Date: Aug 2010
Location: Ft. Worth, Texa$ (With a dollar sign)
Posts: 445
 
Listen to the video link I have on my loud CVT post and see if that's the same noise.
Stonent is offline  
post #8 of 25 (permalink) Old 09-29-2010, 01:40 PM Thread Starter
Junior Member
 
Join Date: Jul 2010
Location: Texas
Posts: 10
 
Angry Heard of this?

Finally got fax from dealership (after calling 1-800 number). Paperwork says "Internal Circuit Failure in PCM Circuit to TCM"; Replace PCM program and road test ok at this time."

Anyone get this response? If so, did it fix the problem?

I will find out and let you know...$630 later...
WeaponZero is offline  
post #9 of 25 (permalink) Old 09-29-2010, 09:43 PM
Senior Member
 
Join Date: Aug 2007
Posts: 263
 
Hmm - this would be real interesting if the wine was caused by a electrical failure. keep us updated.
roberttroll is offline  
post #10 of 25 (permalink) Old 09-30-2010, 10:30 AM Thread Starter
Junior Member
 
Join Date: Jul 2010
Location: Texas
Posts: 10
 
Go it back

Okie dokie...going to the ranch this weekend, so will let you know if problem is gone...

I did call Jeep and do have a case number.

The dealership said the warrenty was for 'lubricated parts only in the powertrain"...they replaced the POWERTRAIN CONTROL MODULE (PCM)...I asked how can the part that contols the transmission NOT be int he warrenty? I got the "lubricated parts" speech again.

I am going to fight that. I looked at my warrenty papers and online and could not find the lubricated clause...maybe it was a memo to Jeep service centers???

Will let you know Monday after the trip...
WeaponZero is offline  
post #11 of 25 (permalink) Old 09-30-2010, 10:51 AM
POTM Winner AUG. 09.
 
tiptronic's Avatar
 
Join Date: Jul 2007
Location: Cheltenham , Gloucestershire UK
Posts: 4,677
 
Send a message via Skype™ to tiptronic
Oh dear ...Not another American dealer who shouldnt really be in business----A WARRANTY is a WARRANTY is a WARRANTY----It covers everything!!!!!!!They shouldnt tell PORKIE PIES about it --Its no skin off their nose--they claim it all back from Chrysler anyway. Its just the fact that they are Lazy & cant be Arsed!! Its far easier to Fob you off & hope you go away!!

Just swapped red Classic X , for, Green Auto SE " Spirit " 2.5 Petrol Limited edition X still 4x4,


Ex 07 Patriot CRD Sport , UK ( with lots of chrome goodies )
tiptronic is offline  
post #12 of 25 (permalink) Old 03-22-2012, 09:11 PM
Junior Member
 
Join Date: Mar 2012
Posts: 2
 
CVT Trans Problems

I have a 2008 Jeep Patriot & I love it, but just recently my family & I were on our way home from Visiting family in Whittier CA. We live In Victorville CA. & on our way up on the 15frw going up the Cajon Pass, & our Jeep started making a winding noise, & started to loose power just like everyone else is experiencing. The Transmission overheating light came on slowed down drasticly. I took the Jeep into the dealership & they told me that it was the CVT going out on it & that it was not under warenty, My jeep only has 76,000 miles on it, & they are telling me that I will have to replace it out of pocket. I took it in to get an estimate & they told me it would cost me $3500 with parts & labor. I just want to know why if this is happening to alot of jeeps, why Jeep won't have a recall on them & fix it for all its loyal Jeep owners??? Did anyone get any help from Jeep Corp. & can anyone help me out??????
Gbarron is offline  
post #13 of 25 (permalink) Old 03-23-2012, 01:49 AM
Cherokar!

 
Tyler-98-W68's Avatar
 
Join Date: Mar 2008
Location: Saskatoon, SK
Posts: 2,959
 
Does it sound like this




If so your cvt is probably on the way out, I traded my patriot off on my current compass before the noise got real bad (wasn't making any sounds when I did my trade in evaluation)

I had 69000 miles on mine when it started making sounds.

2016 Cherokee Trailhawk V6
3.2L V6
Interior LED Conversion
LED Signal Lights
AFE Intake
Tyler-98-W68 is online now  
post #14 of 25 (permalink) Old 03-23-2012, 03:10 PM
Junior Member
 
Join Date: Mar 2012
Posts: 2
 
Did they Get back to you??

Quote:
Originally Posted by sab View Post
A lot of us are experiencing the same with the "07" "08" models. Its probably the CVT. If you search these threads your not the only one. I called Chrysler to complain a week ago and obtained a case #....havent heard from them since, Im only out of warranty for about 2 months
So I called Jeep & they told me they couldn't do anything for me since I am the second owner, & that the case number only applys to you, is there anything you could do to help me out, & get them to do something for me??
Gbarron is offline  
post #15 of 25 (permalink) Old 03-23-2012, 07:23 PM
Member
 
Ant67's Avatar
 
Join Date: Oct 2011
Location: Wiarton
Posts: 83
 
I took my 2011 pat with 14,365ks to the dealership for them to check out the noise coming from my cvt tranny. And to my surprise I'm getting a brand transmission . I got the call today for a time and date for the install. Hope I have no issues after the repair .


Sent from my Autoguide iPhone app
Ant67 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Patriot Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome